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Interface

Interface consist of menu, side tree window, message window, command window and status
bar and tool bars. All interface elements can be controlled by View menu command.

Recommended toolbars layout:

File  Egit w Modity Settngs T

y Setings Tooh e
! EEEEEEETEYY EYFIEETITIEYLYY Iy BTy

R ERLIL RS E

Mosgneccco/ "OI &% surei 0]

i
EREE S A5 R A X | Ik, [P Wk s i@l FENY

-

Side tree window
This window used for control of visibility blocks, layer and colors in database.

- (@ hull (0006)
- )@ hull 5
- (@ hull 6

: . ][5 skeg Add Block

- )@ Inner tanks Delete

Emﬁ Superstructt Explode

- @~ wheelhe
- [C](E ekstra m
- ] @ hulif-ole ST

Include

EHZI uIIf Set fic Current
e E panserm
----- ](E sidetrim i
.7 Thruster Set Entry
- &3 hullm Locked
i Expand visible
I Show all
Quick View
Properties
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Access to block’s available commands provided by clicking with right mouse button on the
block’s name.

Tree » Add Block

This command creates a new empty “Noname” block. Block is become as current. Name can be
changed any time. Position of the block can be changed by drag and drop.

- )@ hull (0008)

- )@ hull 5

=& hull 6
- )& hullm
-l T
E|D hulla (single)
. EI 5keg

O rES Tem e ol

Tree » Delete
This command delete selected block with all elements from database.

Tree » Explode
This command delete selected block and move all elements to parent block.

Tree » Include
Block from external file can be linked to current database by this command. Such block is use
only for visualization. To include block is necessary select external database and external block.

-Ij Open @
_ _ =~ ]&d hull 0
Look in: 7 M ] £F EEv 16
ak in | | pO71 J £ - C]ER hulll
- Name . Date modified Type = (1 hull 2
- £ ; =
e B0 b 10230151043 SHM Fiie. | CJER hull3
Recent Places "'EI hull 4
G- CJ(ER hull 5
4 G- & hull6
Desktop EHZI Fairing
= g hullm
_._-UJ G- [](E8 template
Libraries -5 hulla
A | F e
“ (B Template
Computer o B2 hullf
= Y
¥
Network
Fi 1 b
File name: 0071 (3) shm | QOpen
Files of type: |Shape Maker *.shm ﬂ Cancel

After that insert block to required position.

Tree » Import

Import command is similar to Include with only one difference — all elements from selected block
will be copied into current database.

Tree » Set As Current

Makes selected block current for all new inputted elements. To set block current user can also
click with left button on block icon in the tree.

Shape Maker v2.0 - Marine Software Integration - 4
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Tree » Exit Entry

Cancel entry point settings for tree.

Tree » Set Entry

Set up entry point for the tree. It helps to work with some part of thee as a separate tree.

Tree » Locked

Lock / Unlock selected block for the editing. To set block Lock / Unlock user can also click with
right button on block icon in the tree. Current block can’t be locked.

Tree » Expand Visible

Expand all visible blocks in the tree.

Tree » Show All

Show all database elements as visible.

Tree » Quick View

Show selected block in the new window.

Shape Maker v2.0 - Marine Software Integration - 5
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Tree » Properties
This feature allows viewing properties and adjusting visibility of the elements by their properties.

Properties @

Block |

Comman information

Mame: (0ol Number: |E‘1‘51

Type: |Ir|teri|::r Access: |
Path: |
Show elements Show elements by calar
¥ Poirts v N v N
Iv Lines v A v
[w
I Suffaces v -
v v B
- .
v Sections v ¥ N
[+ Contours v B v Il
v Sizes i+ Vol
[ Details G I Vo
Text attributes
HIDEMT -
- aft ship modified for 3rd CFD

- azimuth headbox rotated 3.5 deg, (mare in line with streamlines)
- volume added transom area outside of headbox

- volume reduced in transom area inside of headbox

- - Send for 3rd CFD 15.08.2014

User can determine which elements in the block will be displayed.
Show elements by color—determine the elements in the block will be displayed.

Text attributes — Additional text information belongs to the block.

Shape Maker v2.0 - Marine Software Integration - 6
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Status Bar

Status bar fields not only indicate current settings status. They can be also used as hot buttons.

Status Bar » Color
|- immsp | MO SCALE | NONE | ELEMENTS | DOMNT | 83.393 10.964 17.564

This field indicated current color. By clicking on the filed user can change current color in
following menu:

Set =

Curment color: -

HE NN
B
N E N =
_ I

| QK | Cancel

Status Bar » Transparency

i TRAMNSP |HO SCALE | MONE | ELEMENTS | DOMNT | 83,395 -10.964 17.564

This field indicated transparency status for surfaces.. By clicking on the filed user can change
current transparency status.

Status Bar » Scale

[ TRense | nOscAlE |NONE | ELEMENTS | DONT | 83.393 -10.964 17.564

This field indicated scale status for model visualization. By clicking on the filed user can change
current scale status.

Shape Maker v2.0 - Marine Software Integration - 7
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Status Bar » Cursor

[ TRensP | NO SCALE | NONE | fLEMENTS | DONT | 83.393 -10.964 17.5564

This field indicated cursor movement type. By clicking on the filed user can change it in
following menu:

Set [l
Marker
£ Nnn = ¢ Dir2d Scale value {mm):
= Ot i+ Dir3d
i~ Dir I'I
™ Dir Pole
¢ Dir Ont [T Scale
™ Dir Line I” Deep

| QK I Cancel

Status Bar » Selection Type

[ TRensP | NOSCALE | NOME |ELEMENTS | pONT | 83.393 -10.964 17.5564

This field indicated cursor selection type. By clicking on the filed user can change it in following
menu:

= ]
Selection T‘;"PE

T Tree

" Block

(+ Hements
ITI Cancel

Shape Maker v2.0 - Marine Software Integration - 8
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Status Bar » Selection Type

[ TRensP | NOSCALE | NOME | ELEMENTS | DONT | $3.393 10.954 17.564

This field indicated shape modification type. By clicking on the filed user can change it in
following menu:

Edit ==

Options |

Distance from approoc. poirts: Bending:
v Draw
2 W Front —
- 2, v Side -
. v Flan -
v 2 [ Gauss'curvature [
b 2 [ By Sections
Edit style: Centers:
{* Point [v Draw

la-\- .
SELL IS L Scale curvature radius by; |100

" Region of points

" Al poirts Madimum radius draw: |50

(" Transform region of points

Mode'_.' connect elements: Modes: Knots:
* Do not modify [ Edit /e
u [v Draw pohbygon

" Al knots except last
" Al knots

Step of curvity: 10 | Curvity of neighbour [v Edit by point

QK | Cancel

Status Bar » Coordinates

[ TRensP | NOSCALE | NOME | ELEMENTS | DONT £3.393 -10.964 17.564

This field show the current cursor coordinates.

Message window

This window used for keep log information of the current working session.

Command window

This window used for input coordinates during working session.

Shape Maker v2.0 - Marine Software Integration -
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Toolbars

Toolbars is used as an alternative interface for menu commands. All commands can be run
from toolbars and from menu. Toolbars fully support Microsoft Windows interface standards.

Context menu

Context menu will appear on some of elements by pointing of the element with right mouse

button and Ctrl button. In general context menu consist of most usable commands for the

element.

Context menu for point:

Edit
Delete

Colar

Properties

Context menu for line;

Edit
Delete
Color
Mawve
Copy
Extend
Attach
Split

Scale

Properties

Context menu for surface:

Edit
Delete
Color
Mowe
Scale

Delete Trimming

Properties

Shape Maker v2.0
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Context menu for driver:

Edit
Delete
Color

Explode

Properties

Hot keys

Alt X, Alt F4
F2
F3, Ctrl O
Ctrl C
Ctrl S
Ctrl P
Ctr IL
Ctrl G
Ctrl X
CtrlY
Ctrl z
F5

F6

F7

F8

F9
F10
F11
F12
Alt F1
Alt F2
Alt F3
Alt F4
Alt F5
Alt W

Shape Maker v2.0

File / Exit

File / SaveAs

File / Open

File / Config

Save

Filter / Point

Filter / Line

Filter / Grid

Filter / GridX
Filter / GridY
Filter / GridZz
Work Plane / Front
Work Plane / Side
Work Plane / Plan
Work Plane / Screen
Marker / Free
Marker / Ort
Marker / Scale
Marker / Deep
View / Front
View / Side
View / Plan
View / Isometry
Set / Isometry

Window / New

- Marine Software Integration - 11
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Alt Q
Alt S
Alt A
Alt D
Alt N

Alt BackSpace

Shape Maker v2.0

Window / Prev
Window / Shift
Window / All
Window / Default

Window / Name

Undo

- Marine Software Integration -
WWW.msi.as
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Menu
File

File Menu contains the file management commands, which allow handling the project files,

prepare the output documentation files, import or export the files.

Edit

View Draw Modify Settin

This command allows creating a new project. Follow the dialog to create a new project.

o B New « | B P |
+| = | Open
Iﬂ B save
Save As
¥
J Cutput L4
Import r
#
s Expart ¥
&
4 Exit
—alll
File » New
.I.ﬂ Mew
Savein: | | Transformations
e Mame .
-y =—
*ﬁam %‘J Forebody r".nu.*.rement.shm
JFDrEhDd}rLlrmt.shm
! _LinesDemo.shm
Desktop fl LocalTransformations.shm
— LW VelumeTransformation.shm
=
Libraries
5 [
A
Computer
A
Metwaorl
1 | 1]
File name: L'rmDa'ncshn
Save as type: |Shape Maker *.shm

-]

£ BB
Date modified

09.02.2015 11:40
09.02.2015 14:09
10.02.2015 09:22
09.02.2015 14:05
09.02.201515:25

=

Type

SHM File
SHIM File
SHIM File
SHM File
SHIM File

=

=]

I
Save |
Cancel

The new project will be opened on the screen with default project settings.

File » Open

Shape Maker v2.0
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This command is used to open an existing project. In the dialogue box select the project file to

be opened.
w1 Open (o3l
Look in: | , DemoProjects j e IfF '
e Mame Date modified Type
‘__'.;‘. = -
Lol Demol.sh 15.06.2014 17:28 SHM Fil
Recent Places J cketl I E
Loy Demo2.shm 15.06.2014 18:50 SHM File
" il Demo3.shm 100820141512 SHMFile
Peklog Demod.shm 13.10.2014 10:43 SHM File
— _'_L"JDemDPru:uject.shm 19.08.2014 15:09 5HM File
r=H
Libraries
LY
Computer
@
Metwork
4 m b
File name: ||Jnes Demo.shm j Open |
Files of type: | Shape Maker * shm | Cancel

The project will be opened on the screen to the state it was saved before.

File » Save
This command allows saving changes in the current project.

Note: After saving user is not able to use Undo / Redo commands for saved changes.

File » Save As
This command allows saving the current project with a different name.

Shape Maker v2.0 - Marine Software Integration - 14
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File » Output
Output menu is used for generation of the project documentation. The output documentation
files are transferred in the DXF and TXT file formats.

Edit Wiew Draw Modify Settings

I
7|
J Cutput r Offset Table
) Import k Flate Expansions
= Export r Screen View Plot
o
4 Exit Wiew Plot
= 3 Views Plot
4 Views Plot

Multi-File Lines
Multi-File Sections

S5hell Expansion

N OB -

With this item Shape Maker will generate set of text documents and sketches in according with
predefined templates.

Shape Maker v2.0 - Marine Software Integration - 15
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Output » Offset Table
This command creates an offset table for all turn on objects of the model.

Export to &3
Table of offset |
Table type: [v Use predefined grid
f* Sections offset table =
(" Lines offzet table g
" Offset table for selected lines
" Section positions table

File name

C:\DemoProjects\Demo Project 4

QK | Cancel |

For export to offset table can be chosen 4 different variants of the offset table:

- Section offset table — hull surface sections point’s coordinates in according to defined
grid.

- Lines offset table — lines point’s coordinates in according to defined grid. The offsets
of the all lines with #IDENT attributes will be created (buttock in CL, knuckle lines, lines
of seems and buts and etc.). The important points of the lines will be transferred
additionally (the initial and end points, knuckle points and other). To get more
information how to set attributes see attribute command.

- Offset table for selected lines — same as previous, but lines can be selected in the
interactive mode. The processed lines are specified by the user. User have to select
begin and end points then select way line to define lines chain if it necessary. After that
enter text identification of the line.

- Section positions table — coordinates of defined grid sections.

Two variants of the grid can be used:

- Same grid as set for model visualization (Use predefined grid-off).
- Grid defined for offset tables only (Use predefined grid-on).

Grid defined for offset table can be set by clicking Set Grids button.

Shape Maker v2.0 - Marine Software Integration - 16
WWW.msi.as



Shape Maker will generate following documents:

- Section offsets table.

| Deme2_TableOffset - Notepad =R <=

File Edit Format View Help

[

| -
shape Maker
06,/29,/13 15:58:02

Demo2
table of offsets buttocks
fr N X 0 10000 20000 30000 40000 50000
-11 -6600 5233 §100 -— -— -— -—
-10 -6000 9477 9549 S S S S

-6000 6723 6940 — — — —
-6000 5206 —— - - - -
-9 -5400 9910 10159 — — — —
-5400 6290 6919 — — — —
-5400 5179 — - - - -
-8 -4800 10084 1077 — — — —
-4800 5154 6897 - - - -
-4800 5151 —— — — — —
-7 -4200 10069 11341 — — — — -

- Lines offsets table.

P "

| Demo2_LineOffset - Notepad =R ==
File Edit Format WView Help
| .
Shape Maker
06,/29/13 16:30:41 1
Demo2 3
Tine Flat side
Tine frames
N X v z N X v z
-9 -5400 11500 B708 40 27000 11500 3605
-8 -4800 11500 877 41 27700 11500 3516
-7 -4200 11500 B748 42 28400 11500 3435
-6 -3600 11500 8721 43 29100 11500 3361
-5 -3000 11500 8691 44 29800 11500 3204
-4 -2400 11500 8659 45 30500 11500 3233
-3 -1800 11500 Bo24 46 31200 11500 3178
-2 -1200 11500 8587 7 31900 11500 3128
-1 -600 11500 8546 48 32600 11500 3086
0 -0 11500 8503 49 33300 11500 3051
Shape Maker v2.0 - Marine Software Integration - 17
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- Sections table.

) Demo2 - Notepad oo e

File Edit Format View Help

[

| -
shape Maker
06,/29/13 16:32:13

Demo2
table of sections frames 5
fr N X fr N X fr N X fr N X
-11 -6600 22 14400 55 37500 BE a0a00
-10 -6000 23 15100 56 38200 89 61300
-9 -5400 24 15800 7 38900 a0 62000
-8 -4 800 25 16500 58 39400 91 62700
-7 -4200 26 17200 59 40300 92 93400
-8 -3800 7 17900 a0 41000 a3 64100
-5 -3000 28 18600 al 41700 a4 a4 800
-4 -2400 29 19300 a2 42400 95 95500
-3 -1800 30 20000 63 43100 9a aa200
-2 -1200 31 20700 6 43800 7 66900
-1 -600 32 21400 a5 44500 a8 67600
0 -0 33 22100 a6 45200 a9 68300
1 a0 34 22800 7 45900 100 69000
2 1200 35 23500 a8 46600 101 69700 =
Shape Maker v2.0 - Marine Software Integration - 18
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Output » Plate Expansions
This command used for output shell plate development information, sketches, templates and
geometrical characteristics.

Shape Maker has following output variants:

- Plate expansion.
Export to @

Plate Expansion | Templates ] Componerts ] Options |

Plates: 7 -
* Plate v
" Unit
. Flate for side: ("
" Unit Sketch ~ cp -~
" Unit drawings & pg -
" Unit templates
(" Weight by frames | Draw line’s names: [One of equals/on ends lines J

QK | Cancel

Plates:
Plate — sketches for one plate.

Unit — unit weight characteristics and COG in the TXT and DXF formats, unit sketch and
sketches for all shell plates in the DXF file format.

Unit sketch - unit sketch and unit weight characteristics and COG in the TXT and DXF file
formats.

Unit drawings — unit sketch in the DXF file format.
Unit templates — shell plates templates for the unit in the DXF file format.

Weight by frames — weight of the unit distributed by frames. Used for weight estimation.

Plate for side:

For the following menu items Plate, Unit, Unit sketch, Unit drawings it is necessary to specify
the type of the unit: SB — if unit only on the starboard, PS - the unit is only for the port side. PS
and SB - for units symmetrical relatively to CL.

Shape Maker v2.0 - Marine Software Integration - 19
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Draw line’s names:

Selection of the visualization type for lines with #IDENT attributes.

One of equals/ on ends lines — one identification in the ends of the lines.
One of equals/ on middle lines - one identification in the middle of the line.
All equals/ on ends lines — all identifications in the ends of the lines.

All equals/ on middle lines - all identifications in the middle of the line.

Plate expansion information - show the unit information.

Pause for show expansion - a pause to show each developed shell plate.

Text height (mm) - height of the text in dxf sketches.

- Templates.

Plate Expansion  Templates | Componerts ] Options |

(" Base line Chord step (m): |02
I Frame Construction :
| Split Template 24

Export to @

Frames: Buttocks: Water lines: Ortha:
v On [ On [ On [ On
[ Middle [ [ [
|+ Edges | | |
v Momal [ [ [
[v Momal Edges [ [ [
v Girid [ [
SL:DI;:ZQH from: Min. height from base line mm): |100 v Back side templates

QK | Cancel

Frames — frame templates type definition.
Buttocks — buttock templates type definition.

Water lines — waterline templates type definition.

Cross normal — templates which are in perpendicular to the normal template.

Shape Maker v2.0 - Marine Software Integration -
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Templates type:

Middle - template passing through the middle of the plate, calculated by the program
automatically.

Edges - templates passing at edges of the plate, calculated by the program automatically.
Normal — middle template of normal to surface.
Normal edges - edge template of normal to surface.

Grid - standard grid templates defined by the project grid.

Show height from: type of the basis on which the templates will be created.
Chord - from chord.

Base Line - from the base line.

Min. height from base line (mm) — minimal height from the base line.

Chord step (m): - chord step to indicate deviations.

Frame Construction - framing construction templates generation.

Split Template - templates splitting by maximal length of template’s material.
Plywood thickness (mm) — thickness of template material.

Plywood length (m) - overall length of template material.

Back side templates — templates from the opposite side of the plating.

Shape Maker v2.0 - Marine Software Integration -
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- Components.

Export to | 23|
Plate Expansion ] Templates Components | Cptions |

Flate 3d model: Plate Mame:

¢ None " Do not include unit name 4 . 4

" Without thickness & Include urit name

£ With thickness [ Lines offset table

v Plate Expansion [ Output to FORAN
|C:"-.Demu:-F‘rc-jeu:ts"-.Demu:-F'n:-jeu:t
0K Cancel

Dialogue box contains options for creating various types of the output files including those in

other formats.

Plate 3d model:

None — no output.

Without thickness — without thickness of the shell plates.

With thickness — with thickness of the shell plates.

Plate name:

Do not include unit name — the unit name will not be included in the shell plate file name.

Include unit name — the unit name will be included in the shell plate file name.

Surface division — subdivision surface for faces visualization.

Lines offset table - generation of lines offset table.

Plate Expansion — plate contours sketches generation.

Output to Foran — plate contours file generation in Foran file type.

File name — the name of the output file.
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- Options.

Export to @

Plate Expansion ] Templates | Components  Options

[ Direct by marking thickness Cut of trace {mm): |50
Shrinkage in frame {mm): |1
{+ {+
~ ~ Plate division: |25

~
1 [ Thickness of adjacent plates

[+ Use arced polyline
[ Hitting Lines [ Bxend short edges

Marking size: |FI‘DITI base "Ad" Dnl‘_-'j [ Start ACAD

QK | Cancel

Setting up shell plates development parameters.

Direct by marking thickness — indication of the marking line thickness direction in the shell
plates sketches.

Direct by:

X — direction of thickness to the bow or stern.

Y — direction of thickness to the side or middle.
Z — upward or downward direction of thickness.
Direct: direction of the framing thickness.

From middle sections — from the middle section
To middle sections — to the middle section.

Middle section — value of the middle section in meters from which direction of the framing
thickness will be determined.

Hitting Lines - hitting lines generation for heat bending method.
Marking size: — type of the marking line end size.

From base A4 only — dimension from the base only in A4 format
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By chain A4 only — dimension by chain only in A4 format
From base R also — dimension in scale 1:1 from base and in development files.

By chain R also — dimension in scale 1:1 from base and in development files.

Cut of trace (mm) - minimal distance between marking line and plate edge in millimeters.

Shrinkage in frame (mm) —shrinkage value per one frame-spacing in millimeters
Plate division — surface patch division for shell plate development.

Thickness of adjacent plates - thickness of adjacent plates considered.

Use arced polyline - arcs used in the polylines.

Extend short edges - extend the development edges

Start ACAD - loads the ACAD program after the plate is developed.
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Output » Screen View Plot
This command creates a copy of the image on the screen in the DXF format.

Visible on the main view part of the project, will be exported to the DXF file.

F

Export to E3
Screen View |

Draw line’s names Set layer/color

* One of equals/on middle lines “ by level

(" One of equals/on ends lines by block/color

" Al equals/on middle lines

" All equals/on ends lines v Use arced polyline
Sections

[ Stat ACAD

* none [+ @

= linked Precision {m): 0.0001

(" standard Text height (mm): &00
File name

CDemo Projects \DemaProject 4

oK | Cancel |

Draw line’s names: - draw line’s names lines with #IDENT attributes.
One of equal/on middle lines — draw name for a line in the center.

One of equal/on ends lines — draw name for a line in the ends.

All equals/on middle lines — draw name for a group of lines in the center.

All equals/on ends lines — draw name for a group of lines in the ends.

Sections: - draw sections lines.
none — no sections lines.
linked — draw section lines (one polyline per one section).

standard — draw section lines for each surface separately (one polyline per one surface patch).

Use own grid — enables or disables usage of the own grid.

Set Grids — changes parameters of the own grid.

Set layer/color: colors used when lines transferring.

Shape Maker v2.0 - Marine Software Integration - 25
WWW.msi.as



by level - one color for all elements.

by block/color - the color of the project.

Use arced polyline - polylines with arcs for lines draw.

Only one arc and one line - Lines and arcs will follow one by one in polyline sequence.

Start ACAD - loads the ACAD program after the plate is developed.
Precision (m) - precision for lines approximation in meters.

Text height (mm) - height of the lines identification text in millimeters.

File name — the name of the output file.
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Output » View Plot

This command creates one of the lines drawing views in the DXF file.

Select the lines drawing view options in the dialogue box.

r

Export to e
View Plot |
Draw line’s names View
* (One of equals/on middle lines " Front v

" One of equals/on ends lines & Siq [ Symmetry Midsh
* Side yrmmetry  Midship:
" All equals/on middle lines

" All equals/on ends lines " Plane [

1

Set layer/color Sections W Use arced polyline

{¢ by level f* none [ [ Only one arc and one ling

(" by block/calar £ linked [~ Start ACAD

" standard
Precizion {m): |0.0001

Text height 600

File name

C:DemoProjects'Demo Project 4

Ok | Cancel |

Draw line’s names: - draw line’s names lines with #IDENT attributes.
One of equal/on middle lines — draw name for a line in the center.

One of equal/on ends lines — draw name for a line in the ends.

All equals/on middle lines — draw name for a group of lines in the center.

All equals/on ends lines — draw name for a group of lines in the ends.

Sections: - draw sections lines.
none — no sections lines.
linked — draw section lines (one polyline per one section).

standard — draw section lines for each surface separately (one polyline per one surface patch).
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Use own grid — enables or disables usage of the own grid.

Set Grids — changes parameters of the own grid.

Set layer/color: colors used when lines transferring.

by level - one color for all elements.

by block/color - the color of the project.

Use arced polyline - polylines with arcs for lines draw.

Only one arc and one line - Lines and arcs will follow one by one in polyline sequence.

Start ACAD - loads the ACAD program after the plate is developed.
Precision (m) - precision for lines approximation in meters.

Text height (mm) - height of the lines identification text in millimeters.

File name — the name of the output file.

View: selection of view.

Front — hull view.

Side — side view.

Plane — plan view.

Symmetry — mirroring lines relative of the middle section.

Midship — position of the middle section in meters.
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Output » 3Views Plot

This command generate a standard lines drawing (three views) in the DXF file.

Visible on the main view part of the project, will be exported to the DXF file.

Export to
3 Views

— Draw line’s names

¥ One of equals/on middle lines
™ One of equale/on ends lines
™ Al equals/on middle lines

" Al equals/on ends lines

— Symmetry

v Front I'u'Iidship:Iﬂ
[~ Side I'u'Iidship:Iﬂ
[~ Plane Midship |ﬂ

[s2]

— Set layer/cal — Secti
Hyerscolor 1ons W Use anced polyline
* by level & none I Use own grid ™ Only one arc and one line
" by block/color Set Grids | [~ Start ACAD
" standard
Precision {m):
Teat height I
— File name
C:DemoProjects’.DemoProject |
oK Cancel |

These options are similar to the View Plot command

Shape Maker v2.0

- Marine Software Integration -

WWW.MmSsi.as

29



Output » 4Views Plot
This command generate a standard drawing (four views) in the DXF file.

Visible on the main view part of the project, will be exported to the DXF file.

Export to e
4 View 2D Plot |
Draw line’s names Symmetry
* One of equals/on middle lines v Front  Midship: |0

" One of equals/on ends lines
[ Side Midship: |0
" Al equals/on middle lines

" Al equals/on ends lines [ Plane Midship |0

Set layer/col Sectl
ayer/color ections I+ Use arced polyliine

0
* by level none o [ Only one arc and one line

(" by block/color £ linked [ Stat ACAD
(" standard
Precision {m): |0.0001

Text height 600

File name

C:A\DemoProjects’DemoProject 4

oK | Cancel |

These options are similar to the 3View Plot command. The difference is that two front views
present on the drawings - one with stations and another one with building frames.
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Output » Multi-File Lines

This command generates a line to the DXF file in one of the projections. Each line is saved in

the own DXF file.

The file name is name given to the line by line’s names lines with #IDENT attributes. To get

more information how to set attributes see attribute command.

" Al equals/on ends lines

v Use arced pobdine v Useownaid precision im): 0.0001
[ Cnby one arc and one line
™ Start ACAD Teat height (mm);  |S00
File name

C:\DemoProjectsDemo Project 4

OK | Cancel |

Export to [ == |
Multi-File Lines |
Draw line’s names View Set layer/color
* (One of equals/on middle lines " Front & by level
" One of equals/on ends lines * Side by block/color
" Al equals/on middle lines " Plane

Draw line’s names: - draw line’s names lines with #IDENT attributes.
One of equal/on middle lines — draw name for a line in the center.

One of equal/on ends lines — draw name for a line in the ends.

All equals/on middle lines — draw name for a group of lines in the center.

All equals/on ends lines — draw name for a group of lines in the ends.

View:
Front — hull view.
Side — side view.

Plane — plan view.

Set layer/color: colors used when lines transferring.
by level - one color for all elements.

by block/color - the color of the project.
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Use arced polyline - polylines with arcs for lines draw.

Only one arc and one line - Lines and arcs will follow one by one in polyline sequence.

Start ACAD - loads the ACAD program after the plate is developed.
Precision (m) - precision for lines approximation in meters.
Text height (mm) - height of the lines identification text in millimeters.

File name — the name of the output files directory.
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Output » Multi-File Sections

This command generates a sections to the DXF file in one of the projections. Each section is

saved in the own DXF file.

Export to

Multi-File Sections |

Draw line’s names
* (One of equals/on middle lines
" One of equals/on ends lines
" Al equals/on middle lines

" Al equals/on ends lines

[v Use arced poldine

[ Cnly one arc and one line
[ Start ACAD

[ Adjust sections
File name

View

" Front
* Side
" Plane

[+ Draw grd
v Use own grid

Set Grids

| £ |

Set layer/color

v/ {* by level
[ Symmetry { by block/calor

-

Precision {m): |[:'-|3'[:'|3l1

Text height 600

C:DemoProjects'.DemoProject

0K | Cancel |

Draw line’s names: - draw line’s names lines with #IDENT attributes.

One of equal/on middle lines — draw name for a line in the center.

One of equal/on ends lines — draw name for a line in the ends.

All equals/on middle lines — draw name for a group of lines in the center.

All equals/on ends lines — draw name for a group of lines in the ends.

View:
Front — hull view.
Side — side view.

Plane — plan view.

Symmetry — mirroring sections.

Set layer/color: colors used when lines transferring.

by level - one color for all elements.
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by block/color - the color of the project.

Use arced polyline - polylines with arcs for lines draw.

Only one arc and one line - Lines and arcs will follow one by one in polyline sequence.

Adjust sections — move zero position of section to ACAD zero position.
Start ACAD - loads the ACAD program after the plate is developed.
Precision (m) - precision for lines approximation in meters.

Text height (mm) - height of the lines identification text in millimeters.

File name — the name of the output files directory.
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Output » Shell Expansion
This command generates a shell expansion drawing.

To develop the shell expansion you need to create the stc file first. The name of the stc file must
be same as project file name and located in the same directory.

1

Export to L&
Shell Expansion |
Shell far Set layer/color Wiew
| Draw frames
{* Left Side by level {" Side
" .
" Plane (" by block/color * Plane v Uss onn gid

£~ Front Set Grids

I+ Use arced poldine

Draw line’s names

* One of equals/on middle lines
[ Cnby one arc and one line

| Start ACAD

" One of equals/on ends lines
" Al equals/on middle lines

™ Al equals/on ends lines Precision (m): |0.0001

Font size (mm): |S00

File name

C:\DemoProjects’DemoProject

QK | Cancel |

Shell for:
Left Side — only for the port side.

Plane — for port side and starboard.

Draw frames - draw the frame lines.

Set layer/color: colors used when lines transferring.
by level - one color for all elements.

by block/color - the color of the project.

View:
Front — body plan view.

Side — side view.
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Plane — plan view.

Draw line’s names: - draw line’s names lines with #IDENT attributes.
One of equal/on middle lines — draw name for a line in the center.

One of equal/on ends lines — draw name for a line in the ends.

All equals/on middle lines — draw name for a group of lines in the center.

All equals/on ends lines — draw name for a group of lines in the ends.

Use arced polyline - polylines with arcs for lines draw.

Only one arc and one line - Lines and arcs will follow one by one in polyline sequence.

Start ACAD - loads the ACAD program after the plate is developed.
Precision (m) - precision for lines approximation in meters.
Text height (mm) - height of the lines identification text in millimeters.

File name — the name of the output file.
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File » Import
The Import menu contains the commands for import data from other CAD/CAM systems.

Import r DXF
Export * IGES

B By % %, M, % g

Approximation points

ASF

-

Import » DXF

Import polylines from DXF file and converts is to Shape Maker curves and approximation points
representation.

Irnport from @

AutoCAD DXF '|

[~ Make Approximation Point Imtemalation precesian {m): |I}.D'I

I+ Make Lines Detect knuckle angle (deg): |3

Maximal Step (m): |I}.1

File name

CDemoProjectstDemaProject 4

Make Approximation Points - Import polyline points and convert it into approximation points.
Make lines - Create Shape Maker curves from DXF polylines.

Interpolation precision (m) — maximum deviation of the Shape Maker curves from DXF polylines.
Detect knuckle angle (deg.) — minimum detected knuckle angle.

Maximal Step (m) — defines minimal length of line segment.
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Import » IGES
Import surfaces from IGES file and convert to Shape Maker surfaces.

Jopen =
Loak in: | | Transformations j IfF '
b= Mame . Date modified Type
-
*ﬁaﬁ [ LinesDemo.igs 11.02.2015 09:08 1GS File
Desktop
=l
Libraries
A
Computer
&
Metwork
4 M b
File name: | ﬂ Open
Files of type: | Shape Maker "igs j Cancel

All surfaces, points and lines will be imported into current block.

Import » Approximation points

This command read points from the LST file to the project file to use as approximation points.

Import from [ == |
List of Approx. points |

Measurement unit {m); |1

File name

C:"DemoProjects®Demo Project

oK | Cancel |
Measurement unit (m) - scale factor.
File name — name of the LST file
Shape Maker v2.0 - Marine Software Integration -
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Import » ASF

This command import the Shape Maker project previously saved in ASF file format.

Irnport from

A.SF'

— Source file name

IC:"\Demu Projects"DemoProject

— Result file name

IC:"\Demu Projects"DemoProject

=
-
I

Source file name — ASF file.

oK

| Cancel |

Result file name — Shape Maker SSL file where with import results.
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File » Export

:[7 Edit View Draw Modify Setting

3 b | Mew
il Open
E B save
Save As
" Cutput L4
utpu
A
Import 4
&
z Export r DXF 3D Model
o
& Exit =
5TC
[ ASF

>

Export » DXF 3D Model
Exports 3D project representation into DXF file.

Lines, surfaces and sections are transferred to the 3D model. The lines and the surface will be
transferred in full, even if only a part of the line or surface is in the window.

Export to @

30 Model '|

Set layer/color Sections

: - v Use arced pobdine
(» level: * none
by level e [ Only one arc and one line

" by block/color i linked 4 [ Start ACAD
(" standard

Precision (m}): |0.0001

File name

Z:"DemoProjects™ DemoProject

Set layer/color: colors used when lines transferring.
by level - one color for all elements.

by block/color - the color of the project.

Sections: - draw sections lines.
none — no sections lines.

linked — draw section lines (one polyline per one section).
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standard — draw section lines for each surface separately (one polyline per one surface patch).

Set Grids — definition of the own grid.

Use arced polyline - polylines with arcs for lines draw.

Only one arc and one line - Lines and arcs will follow one by one in polyline sequence.
Start ACAD - loads the ACAD program after the plate is developed.

Precision (m) - precision for lines approximation in meters.

File name — the name of the output file.

Export » IGES

Export to the IGES file format.

_d Save As @

Save in: | , Transformations j IfF '

L Mame Date modified Type

- b
oo LLinesDemoigs 110220150908 1G5 File

Desktop
=}l
Libraries
Ly
Computer
1Y
Metwork

4 L k

File name: L'rmem:l ig j Save
x|

Cancel

Save as type: |Shape Maker ~igs
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Export » STC
Export to the STC file format for hydrostatic calculations.

STC '|

Mission:

" Prepare lines group

i R

Output format :
{* Sea Hydro (stc)
" AutoHydro (gf1)

Room type: Geometry:

[~ Max. Draught {m); |C
+ Hull * Symmetrical ght m)

" Tank " Right side ¥ Useowngid [ Use optimization

" Selection " Left side Set Grids |

Precisian {m): |[:'--I

File name

Export to @

C:\DemoProjects \DemoProject

Mission:
Export to STC-file — creating of STC file.

Prepare lines group — lines groups definition.

Lines Group:

Explode group — delete existing group

Add Water Line Group — standard margin of safety line definition.
Add Center Line Group — buttocks in CL definition.

Add Hatch Group — hatches and other openings line definition.

Output format:

Shape Maker— Shape Maker STC file
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AutoHydro — gfl file

Room kind:
Hull — hull.
Selection — compartment.

Tank — tank.

Type:
Symmetrical — symmetrical.
Right side - starboard.

Left side - port side.

Max. Draught — maximum loaded draught
Use own Grid - use none projects grid.
Use optimization - optimize number of line points.

Set Grids - formation of the own grid.

Precision — precision of the sections representation.

Export » ASF

Export to the ASF — project database text file dump.

Export to
ASF |
Elements
o [
o Al
-

(" Chosen by user

(" Block tumed on Precision {m): |2

File name

C:\DemoProjects'\DemaoProject

oK | Cancel |

Elements:

Shape Maker v2.0 - Marine Software Integration -

WWW.Mmsi.as

43



All — all elements of the project will be transferred.
Chosen by user — only specified elements will be transferred.
Block turned on — only visible elements will be transferred.

Include references - elements, which correspond to direct references, will be additionally
transferred.

Include back references - elements, which correspond to back references will be additionally
transferred.

Precision — precision of the text representation of the floating-point digits.

File name — name of the file where data will be stored.
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Edit
Menu Edit contains commands that allow undoing/redoing an operations and rebuilding the
project elements.

dify Se

181 | Update Model

o Hikak

Edit » Undo

Undo command undoing previous edit operation.

Edit » Redo

Redo command redoing previous undo operation.

Edit » Update Model

Rebuild some elements of the project.

Update Model |

" Rebuild Al
" Rebuild some elements
" Update Shell Plates

| QK | Cancel

Action:
Update Profiles — all profile details will be rebuilt
Rebuild All - all elements will be rebuilt

Rebuild some elements — only the element specified by the user and all other elements on
which this element depends will be rebuilt.

Update Shell Plates — all plates of the project will be rebuilt.
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View
View menu contains commands for visualization of the project and user interface managing
tools.

Settings Toold

File Edit [[7°7] Draw Modify

Volume

..... .Elﬁ lj Front
..... ¥ E2) sice

™.  Flan

@ Isometry

3D Views k
A2 Set View Point
|ﬂ~ Transparency
¥ Stretch

“t.<

Redraw

Application Look k
ToolBars Docking Windows k

v | Status Bar

ISk - (S F 2 IIN

View » Volume
The Volume menu commands are used to manage size and position of the current visible
project volume.

File Edit /"' Draw Modify Settings Tools Help
Yolume MNew
Previous

By Model Limits
By Grid Limits

b o

Front
Side

Plan
By Mame

5hift To Forward
Shift To Aft

Isometry
30 Views
Set Wiew Point
Transparency Pan

Stretch Zoom

CRe Lomas

Redraw

Application Look
ToolBars Docking Windows

Status Bar

"
O
g
M
o
o
@
#
e
‘o
It
I
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Volume » New
Set volume rectangle for the current projection.

Select Begin and end points of the rectangle to define new volume size and position on the
current projection.

By request in the command line: "First corner: 0, 0, 0". Enter the coordinates or define position
of the first point by the cursor. Move the marker, indicating boundaries of the visible window.

By request in the command line: "Second corner: 0, 0, 0". Enter the coordinates or define
position of the second point by the cursor. An enlarged image of the model will appear on the
screen.
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Volume » Previous
Return to previous project volume.

Volume » By Model Limits
Set up project volume by maximum visible model dimensions.

Volume » By Grid Limits
Set up project volume by project grid dimensions.
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Volume » By Name
This command allows saving 10 named volumes.

1. Set the required project volume.

2. Select the command Volume » By Name from menu.
In the dialogue box enter name of the window to be saved.

Vaolumes List @

Forebody
Afthody
Thruster

hast
superstructure
Mo name

Mo name

Mo name

Mo name

Mo name

4 I ¥

(o]4 Cancel

Volume » Shift to Forward
Shift current volume in direction "to user”.

Before:
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Volume » Shift to Aft

Shift current volume in direction "from user”.

Before:
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Volume » Pan
Pan command is used for positioning visible objects in the window without changing current
volume.

Before:

After:

Volume » Zoom
Zoom command is used for zooming in/out visible objects in current window.

Before:
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Volume » Rotate
Rotate command is used for rotating current volume in the window. Available only in 3D view.

Before:
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View » Front
Front command is used for setting the current view Front.

View » Side

Side command is used for setting the current view Side.

View » Plan
Plan command is used for setting the current view Plan.
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View b Isometry
Isometry command is used for setting the current view as 3D view.

View » 3D Views

3D Views menu commands are used to set 4 standard Viewpoints.

: File Ed'rt Draw Modify Settings Tools Help

B & QM

Volume

EI@ D Front
EI'E E| side

Plan

Isometry

3D Views k South-West
South-East
Morth-East

MNorth-West

Set View Point

™
@
2
ﬂ Transparency
=
“m{

DO D

0¥ | stretch
Redraw

Application Look L4
ToolBars Docking Windows  #

v || status Bar

[ &% - (2T F 2 [N
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3D Views » South-West
This command set up the current point of view as South-West.

3D Views » South-East
This command set up the current point of view as South-East.

3D Views » North-East
This command set up the current point of view as North-East.
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3D Views » North-West
This command set up the current point of view as North-West.
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View » Set View Point
This command set up user defines view point for 3D view.

View @

Wiew point |

+ Nectror, Vector: |1.0,0
Two points
Three points
Tangent to line

~
~

~

" Two tangents
" Poirt and tangent
~

Momal to suface

QK | Cancel

The View Point can be set up by the following methods:

Vector — arbitrary vector.
Select Vector from the list. Input vector coordinates into the Vector field, then click OK .
Two points — vector determined by two points.

Select Two points from the list. Click OK. Input first and second points by cursor or
coordinates.

Three points — vector as normal to plane determinate by three points.

Select Three points from list. Click OK. Input first, second and third points by cursor or
coordinates.

Tangent to line- vector as tangent to line.
Select Tangent to line from list. Click OK. Select by cursor line for tangent determination.
Two tangents — vector as normal to plane, parallel with two tangents.

Select Two tangents from list. Click OK. Select by cursor lines for tangents
determination.

Point and tangent - normal to plane determined by point and tangent to line.

Select Point and tangent from list. Click OK. Input point by cursor or coordinates. Select
by cursor line for tangent determination.
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Normal to surface — vector normal to surface.

Select Normal to surface from list. Click OK. Select by cursor surface for tangent determination.

View » Transparency
This command switches transparency of the surfaces.

Transparent surfaces:

Not transparent surfaces:

View » Stretch

This command set up scale factors in axes X, Y, Z and performs transformation of the image.
This transformation affects only visual representation of the model.
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View @

Stretch view |

QK Cancel

Enable - enables the transformation.

Enter the scale factors in axes X, Y, Z. An image in accordance with the entered factors will
appear on the screen.

Before:
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After:

View @

Stretch view |

V¥ Enable X {m): (0.5
Y {m): |1
Zim)k 1

| QK | Cancel

View » Redraw
This command redraws images of all visible elements.
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View » Application Look
By this command user can choose different looks of the program.

L
: File Edit ﬁ Draw Modify Settings Tools Help
Volume {E @\ E}\| <1ty @l (ol -

Front

EZ | side

Plan

Isometry

30 Views

Set View Point
Transparency

Wk | stretch
Redraw

Application Look Windows 2000
ToolBars Docking Windows Office XP
Status Bar Windows XP
Office 2003
Visual Studio 2005
Visual Studio 2008
Office 2007 Blue Style
Windows 7 Elack Style
Silver Style

Aqua Style

View » Toolbar Docking Windows
By this command user having access to Windows standard toolbars docking options.

View » Status Bar
This command switch on/off status bar visibility.
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Draw

Draw menu contains commands for input new graphical elements into the project model.

File Edit View |27 Modify Settings
EEE o o Line »
o D'ﬁ hull I:I Rectangle
..... W hull | = Point
- @8 huli2 FA  Intersection

Cutout k
Surface k

Diriver r

Approximation Points
Divide
Tangent
Arc

Dimension

Jd 0Ty

P - [ BT F o O

Draw » Line
This command is used for input any type of lines into the project model.

Settings Tools Help

File Edit View | /=07 Modify
iEEEl v o Line M | Line

- Dlﬁ hull I:I Rectangle yus | Spline

5 hull | =  Point Ja | BSpline

L CI(E hull2 F*  Intersection o | Bezier
Cutout M S Knuckle
surface ' Q Surface Line
Driver r

Approximation Points L
Divide
Tangent
Arc

Dimension

My &

LN - (B F QOO
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Line » Line
Draw straight line between two points.

Input first point of the line by cursor or coordinates. Input second point. New line will appear in
the model. Input new second point - new line will appear. And so on. To stop input lines chain
press Esc button or right mouse button. To stop lines input press Esc button or right mouse
button one more time.

Line » Spline
Draw spline by the set of points.

Input first point of the line by cursor or coordinates. Input second point. New line will appear in
the model. Input next point. Resulting line will pass all inputted points. To stop input spline press
Esc button or right mouse button. To stop splines input press Esc button or right mouse button
one more time.
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Line » B-Spline
Draw b-spline by the set of points. To draw b-spline curve by control polygon minimum four
points required.

Input first point of the line by cursor or coordinates. Input tree more points. New b-spline will
appear in the model. Resulting line will follow control polygon of b-spline. To stop input b-spline
press Esc button or right mouse button. To stop b-splines input press Esc button or right mouse
button one more time.

Minimal control polygon:

Control polygon and b-spline:

Control polygon and b-spline with more control points:
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Line » Bezier
Draw Bezier by the set of points. To draw Bezier curve by control polygon four control points
required.

Input first point of the line by cursor or coordinates. Input tree more points. New Bezier will
appear in the model. To stop input Beziers press Esc button or right mouse button. To stop
Beziers input press Esc button or right mouse button one more time.

Line » Knuckle
Detect knuckle lines inside surface.

Select surface for detecting knuckle lines. Detected knuckle lines will appear in the model.
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Line » Surface Line
By this command user set up surface lines mode. All lines inputted in this mode lines will belong

to current surface.

Line on surface:
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Draw » Rectangle
Draw rectangle between two diagonals points. The rectangle consist of four boundary lines and
surface inside.

Input first point by cursor or coordinates. Input second point. Rectangle will appear on screen.
Input new point to start new rectangle. To stop rectangles input press Esc button or right mouse
button.

Draw » Point
Calculate intersection point between two lines.

Select first line. Select second lines. Intersection point will appear on screen.

Draw » Intersection
Calculate intersection line between two surfaces.

Select first surface. Select second surface. Intersection line will appear on screen.
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Draw » Cutout
By this command user can make cutouts for lines and surfaces.

i File Edit View “ Modify Settings Tools Help

el g e MBR O ME D

o D'ﬁ hull I:I Rectangle

5% hull | =  Point

- ]38 hull2 F*  Intersection
Cutout b .7 Online

Surface ¥ & OnSurface

Driver r
Approximation Points
Divide
Tangent
Arc

Dimension

J T

BB - (B Y F o [ONG
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Cutout » On line
Hide part or parts of the line.

Select begin point on line to make cutout. Select end point. Part of the line between selected
points will disappear from the screen.

Both selected points must belong to the same line.

Before:

After:
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Cutout » On surface
Hide part or parts of the selected surface.

Select line by line closed contour on the surface. Part of the surface inside cutout will disappear
from the screen.

All selected lines must be connected each other and belongs to the same surface. Two cutouts
cannot have same boundaries or intersections.

Current version of the Shape Maker support outer and inner contours of the trimming. Most
outer contour is surface boundary contour. Inner contours holes. So if necessary to define hole
— two contours should be presented: hole itself and outer contour as surface boundary.

Before:

After making inner contour:
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After making outer contour:

Draw » Surface

i File Edit View ﬁ Modify Settings Tools Help

e laaa nd
o D'ﬁ hull I:I Rectangle
5% hull | =  Point
- ]38 hull2 F*  Intersection
Cutout 4

Surface k

'C? Murbs
Driver H| & Shell Plate
& slot

Approximation Points 4

Divide

EERERE"NY

Tangent

Arc

J T

Dimension

5%"% :

Surface » Nurbs
Draw Nurbs surface.

Select line by line closet contour. Nurbs surface will appear in the model.

Selected lines must be connected each other. Nurbs surface contour can contain from 2-4
boundaries.
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Before:

After:

Possible number of the boundaries for Nurbs surfaces:

Surface » Shell Plate
Define ship hull shell plates on the set of hull surfaces.
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Select line by line contour of the shell plate and press Enter.

1-101710.0

1-103{10.0

Fill all necessary field in Shell plate definition menu:

Set =

Shell Plate |

Plate number: |

Precision {mm): lll“li
Thickness {mm]: l'll}i

Shit fom): [5
Density fcg/m3): IW

Project name: |DE|T"I'

Drawing number: ||-E"|3"I

Part name: |‘I-1 02

|dentficator name: |5HELL

Material: |;’-‘-.

[+ Cortrol Plate Expansior

| QK | Cancel

Precision - development precision.

Thickness - plate thickness.

Shift - plate thickness deflection.

Density - material density.

Project name - parameter for Foran system.
Drawing number - parameter for Foran system.

Part name (Foran panel) - part number.
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Identificator name - comments for the name of the part.
Material - material grade.
Control Expansion — visual checking shell plate expansion.

Select orientation and press Enter.

[

1-101/10.0

1-10310.0

Click on plate if necessary to change propossed thickness orientation. Then press Enter.

If Option Control Expansion was switch on following dialog will appear:

Shell Expansion @

Flate: |22942 "-1me Center of Grawity: ‘49.54?, 2267, 8495 m
bin. Area Dimentions: |5.U1555*2.93811 m Boundary Stretching: ‘min =-01 %, max=00%
Min. Wictth Dimentions: |5.01588 293811 m Areadefect [02% (000nsew)
Area; |1 3.78B5 (13.7865) m2 Applied deformation:; ‘ 0.0 %

Surface » Slot
Define set of similar cutouts on surface along surface line. Used for slot welding marking.
Geometry of the cutouts should be predefined in separate block.
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Open slots library, choose required slot and then click Open.

~.3 Open (=)
- - - " . ---D template
Lok in: | DemaProjects j & £ El hul
= Name Date modified Type =] ([ Slots
T - =
e i Demol.shm 15.06.2014 17:28 SHM File DM
Recent Places - X
ﬂ Demo2.shm 15.06.2014 18:50 SHM File
" il Demo3.shm 190820141512 SHMFile
Desktop i‘él Demod.shm 1310.2014 10:43 SHM File
. ﬂ DemoProject.shm 19.08.2014 15:09 SHM File
=i
Libraries
Computer
@
Network
4 Tl 3
File name: |Dem03.shm ﬂ Open
Files of type: |Sha|:-e Maker *shm j Cancel

Select begin and end points on the surface line.

Set necessary parameters and click OK:

Set 5ol

Slot Options |

Distance from first paint (mm): 77

Distance from second point (mm):

i
Step {mm): |83

| OK | Cancel |
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Slots will appear in the model.

Draw » Driver
e,

i File Edit View _ Modify Settings Tools Help

Rl s g Line B & 2| M E

"
O
PRt
e
ey
o
@
&
e
o
It
1

Shape Maker v2.0

@@ hull

#&d huln

.

Rectangle

Paint

Intersection

Cutout

Surface

Drriver

Approximation Paoints
Divide

Tangent

Arc

Dimension

NGRS

Fillet
Rotation
Extrusion
Pipe
Profile
Offset
Webbed
Explode
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Drivers are a set of element build in according predefined rules: Surface of extruding, rotation
and etc. User can edit drivers by changing parameters or geometry of elements which driver
depend.

Driver » Fillet

Fillet is used for obtain a smooth conjugation of two lines by a line of an arc or a straight line.

Drriver @
Fillet '|
Fillet Fillet Type
(+ Between two fines " Straight
{” From paint to line * Arc
{" From paint on line to anather line " Rathole
W Auto detect plane Radius {m): (0.1
[v Cut free ends
v Put to suface Plane: |D' 1.0
QK | Cancel

Select the fillet construction method and other required options.
There are three methods for creating a fillet.

Between two lines

From point to line

From point on line to another line

Fillet type:

Straight — straight line fillet;

Arc — arc fillet;

Rathole — rathole fillet;

Auto detect plane - automatic detection of the projection where the fillet will be of an arc shape:
Cut free ends - cutting the “free” ends of the mated lines.

Put to surface — make a surface line fillet.

Radius — value the arc radius.

Plane — normal to projection plane, on which the line should be of an arc shape.
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Fillet between two lines:

Select first line. Select second line. Fillet driver will appear in the model. To stop creating the
fillet press Esc or right-click the mouse

Before:

After:

Fillet from point to line:

Select the starting point of the fillet line. Select line to which the fillet will be created. To stop
creating the fillet press Esc or right-click the mouse.

Before:
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After:

Fillet from point on line to another line. Radius will be calculated automaticly.

Select the starting point of the fillet line. Select the line, to which the fillet will be created. To stop
creating the fillet press Esc or right-click the mouse.

Before:

After:
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Driver » Rotation
Rotation is used to create surfaces by rotation of the forming lines around the axis.

Select the axis of rotation. Select a set of lines for rotation. Enter the angle of rotation. To stop
creating the driver of rotation press Esc or right-click the mouse.

Before:

After:

Driver » Extrusion
Extrusion is used to create surfaces by extrusion the forming lines along the directional line.

Select the method of extruding.
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Drriver @
Extrusion |
Type
" By direct iine: " By surface edge
| QK | Cancel
By direct line:

Select the directional line. Select a set of lines for extrusion. To stop creating the driver of
extrusion press Esc or right-click the mouse.

Before:

After:

By surface edge:

Select boundary of the surface. Extension of the surface is created to the length specified in the
dialogue box.
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Before:

Driver » Pipe
Pipe is used for development of pipelines.

Select the pipe construction method, as well as desired parameters and options.

Diriver @

Fipe |
Trace:
Diameter {m): 0.05
" Single pipe
" Pipeline Fillet Radius {m}): |1
@ filetedpipeine | [ Cut free ends

oK | Cancel |

Trace: method for tracing the pipe:

Single pipe — created on a segment of a single line;
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Pipeline — created on a chain of lines;
Fillet pipeline — created on a chain of lines

Diameter — diameter of the pipe;

Fillet Radius — fillet radius of the trace line;

Cut free ends - cut free ends of the lines;
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Single pipe:

Select a first and end points of the line segment. A pipe surface is created. To stop creating the
pipe press Esc or right-click the mouse.

Before:
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Pipeline:

Select begin point. Select end point. Pipeline will appear in the model. To stop creating the
pipeline press Esc or right-click the mouse.

Before:

After:
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Fileted pipeline:

Select begin point. Select end point. Pipeline will appear in the model. To stop creating the
pipeline press Esc or right-click the mouse.

Before:

After:
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Driver » Profile
Profile is used for creating profile surfaces by tracing the profile along the directional line.
Geometry of the profile should be predefined in separate block.

Select block with profile geometry:

Fopen =
) - B —— EIiZ":l template
Look: in: D Project - g - £
i | emoProjects J [ £ -1l profile
i Name Date modified Type - B midel
Hm‘;}j} &l pemol.shm 15.06.2014 17:28 SHM File ~#)E main deck
aces ) H T
2l pemo2.shm 15.06.2014 18:50 SHM File )8 NewProfile
" 2 bemo3.shm 100220151002  SHMFile E‘g :lL"t'
Desktop i Demod shm 13.10.2014 10:43 SHM File HE‘ O r__? ;ﬂﬂoﬂ
. i DemoPraject.shm 19.08.2014 15:09 SHM File
pemetro - o
L
Libraries
Computer
A
Metworkc
Ll T F
File name: |Dem03.shm ﬂ Open
Files of type: |Sha|:-e Maker *shm j Cancel

Then click Open. Select begin and end points of the directional line. Answer Yes if profile shoul
be normal to surface.

ShapeMaker v1.00 £Z

[9} Do you want to set this profile by normal to surface (y)?

Select profile orientation:
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Profile will appear in the model.

To stop creating the profile press Esc or right-click the mouse.

Driver » Offset
Offset is used to create a line or a surface equidistant from another line or surface.

Line:

Select line for offset.

Click on selected line one more time to change offset direction. Press Enter.
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Fill offset parameters in dialogue box:

Set [l
Offset |
i Shift {mm):
~
~
~
| QK | Cancel
Direction:

Normal — offset direction by normal to original surface.

Frames — offset direction by normal to original surface on front projection.
Buttocks — offset direction by normal to original surface on side projection.
Waterlines — offset direction by normal to original surface on plan projection.

Shift — offset value.

Offset line will appear in the model.

To stop creating the offset press Esc or right-click the mouse.
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Surface:

Select surface for offset.

Click on selected line one more time to change offset direction. Press Enter. Fill offset
parameters in dialogue box:

Set [l

Cffset |

Shift {mmy):

B IS T I

| QK | Cancel

Offset surface will appear in the model.

To stop creating the offset press Esc or right-click the mouse.
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Driver » Webbed

Webbed is used to create a smooth rounding edge of two surfaces.

In the dialogue box select the construction method and other required options to create a
conjugation surface.

To create a conjugation it is necessary to select the surfaces to be rounded and the axis line.
The rounding surface is created in the way that its section by any surface, intersecting the axis
line parallel with it, is of an arc shape. In the end points such arcs are smoothly jointed with the
mated surfaces. Arcs that correspond to beginning and end of the axis line are the butt edges of
the mating surface.

For method constant (New arcs):

In the text field Value enter the conjugation radius. Confirm the selected value by clicking OK.

Diriver @

Webbed |

Ends

* Mew arcs
(" Bsdsting fillets

Radius
™ by seam line

{* onstant Value: |1

(" linear dependence  End radiuses: |1- 1

" by b-spline

0K | Cancel

Select the first surface. Select the second surface. Select track line.
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Webbed will appear in the model.

I S|

To stop creating the webbed press Esc or right-click the mouse.
For method linear dependence (New arcs):

In the text field Radiuses enter the starting and ending radius of conjugation. Confirm the
selected value by clicking OK.

Drriver @

Webbed '|

Ends
* Mew arcs
(" Bxisting fillets

Radius
" by seam line

" constart Value: | 1

{* linear dependence  End radiuses: |'|-2

" by b-spline

| QK | Cancel
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Select the first surface. Select the second surface. Select track line.

Offset surface will appear in the model.

To stop creating the webbed press Esc or right-click the mouse.

Driver » Explode
This command is used to “explode” the driver or some elements of the driver.

After exploding all elements of the driver become independent elements.

Exploding the element will make it driver-independent: the element can be corrected as a usual
element but cannot be deleted.

In the dialogue box select the driver “stripping” method.
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Drriver @

Explode '|

i¥ iDriverE {" One Blement

| QK | Cancel

For method Driver select the driver to be exploded.

For method One Element select element of the driver to be exploded.

Driver » +/-
This command allows adding a new element to the existing driver of similarity or removes its
element.

Select the driver of similarity. All elements of the driver will temporarily be highlighted red. Select
the elements. New elements will be added to the driver or driver elements to be removed from
the driver of similarity.
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Draw » Approximation Points

: File Edit View - Modify Settings Tools Help

i E Rl g e B & S E

(- 7] templ{ I3 Rectangle

i 7] hull = | Point

B EI Slots # Intersection

s || 77 Bilge k Cutout b

M Surface 4

£ Driver k

.??'.hu Approximation Points — »| %5 pdd
i &f  Divide ¥t | Delete
L £ Tangent e | Include
73 ¢ | Arc ¥ | Exclude
e 7% | Dimension A~ Mave
-

This menu contains commands that allow the approximation points to be assigned to and
deleted from the lines or surfaces and to be further used for adjustment of the lines and
surfaces. You can also adjust the approximation point coordinates.

Approximation points may also be loaded from the DXF-file or a special file.

Approximation Points » Add
Add command allows the new approximation points to be inserted for a specified line or surface.

Select the element. Input the approximation points by mouse of by coordinates. To stop the
insertion press Esc or right-click the mouse.

Approximation Points » Delete
This command deletes the approximation points. Select the point. The approximation point will
be removed from the project.

Approximation Points » Include
This command assigns approximation points with line of surface.

Select the element to which the approximation points will be assigned. Select approximation
point.

Approximation Points » Exclude
This command excludes an approximation point from the line or surface.

Select the element from which the approximation points will be excluded. Select the
approximation points.

Approximation Points » Move
Move the approximation points, which belong to an element.

Specify the approximation points to be moved.
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Select points to move and press Enter. If one point selected — move to new point position. If
several points were selected follow instructions to move group of points.

Draw » Divide
This command is used to divide a line into two lines in the specified point.

Select the division point in the line. Select the required option in the following dialogue box:

ShapeMaker +v1.00 EE

IGI Replace original line with two new (y)?

Two new lines will be created that exactly follow the shape of the source line. To stop the
command press Esc or right-click the mouse.

Draw » Tangent
This command is used to create tangents to the lines.

Select the tangent type in the dialogue box.

Create @

Tangent |

Tangent Type

" Between two lines

Angle with tangent: |I]I

Flane nomal: |D. -1.0

| oK | Cancel |

Angle with tangent — angle of slope to the tangent (for the type from point to line)

Plane normal — normal to projection.

From point to line:
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Define the first point of the tangent. Select line where you going to make tangent.

Between two lines:

Select first line. Select second line.

Draw » Arc
This command is used to create arcs.

Select the arc type, radius and other required options.

Create @

Arc Type Orientation
{* Two points and radius; {" Positive
(" Three points {* Negative

" Center and Radius

Radius {m): |1 Plane nomal: |0.-1.0 [ Bighrc

QK | Cancel

There are 3 methods for creating an arc:
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Two points and radius
Three points

Center and radius

Orientation: orientation of the arc.
Positive — counter-clockwise direction.

Negative — clockwise direction.

Radius — value of the arc radius, given in meters.
Plane normal — normal to projection plane.

BigArc — an arc with a smaller or larger central angle.

Two points and radius:

Select the second point of the arc. A new arc will be created. To stop input the arc press Esc or
right-click the mouse.

Three points:

Select the first point. Select the second point of the arc. Select the third point of the arc. A new
arc will be created. To stop input the arc press Esc or right-click the mouse.

Center and radius:

Select center of the arc. Define the beginning angle of the arc. Define the end angle of the arc.
A new arc will be created. To stop input the arc press Esc or right-click the mouse.
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Draw » Dimension

This command allows setting the linear, radial and angular dimensions.

Select type of the size and necessary parameters in the dialogue box.

Define
Dimensions |
Type
-
" Radial dimension
=

" Angular dimensior

Direction for linear dimension
" Vector
" Auto
{+ Auto orthogonal

==

| QK | Cancel

Linear dimension:

Select the first point of the linear dimension. Select the second point of the linear dimension.
Select the text location point. The linear dimension will appear in the model.

Radial dimension:
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Select a point on the arc through which the dimensional line will pass. The specified radial
dimension will appear.

Angular dimension:

Select point of the first line. In this case the geometrical snap Point must be enabled. Select any
point of the second line. In this case the geometrical snap Point must be enabled. The
dimension with the text will be displayed on the screen.
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Modify

Modify Menu contains commands that allow modify the geometrical characteristics of elements.

i File Edit View Draw Settings  Tools

EEE v | R Attribute
El template Copy Attribute

Delete

'"EI Slots Element
.7 Bilge keel Block

Colar

Properties

Modify » Attribute

This command is used for attachment of the different text attributes to elements.

Editor ==
#IDENT Buttock in CU = oK |
Cancel

Modify » Copy Attribute

This command is used for copy attached text attributes to other elements in the model.
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Select source element with the text information. Select element to copy text attributes. Edit text
attributes in text editor if necessary.

Modify » Delete

This command deletes any element from the project that no other element has a reference to.

Select an element or elements to be deleted depending on the current method of selecting an
element (see Selection Type).

Modify » Element

: File Edit View Draw _ Settings Tools Help

D o ca || B IP | Attribute @ C M E D e
|| F- 7] [ template I} | Copy Attribute

_____ & hull 7 Delete

'"EI Slots Element h
.71 Bilge keel Block >

Color

Joint
Straiht
Smooth

Knot

s

Properties

Fixing

Surface Crientation
Ortho Line

Orthao Surface
Tangent

Connect

Extend

Knuckle

STV - [ BB FE LI

Copy Geometry
Update
Rebuild

@ 2BFE BB &L FF NN

Options

ANTE

Element » Joint
This command is used to smoothly join a current edited line or a surface to another line or
surface. Before use this command line or surface should be chosen for edit.

For line:

Select the type and parameters of joining.
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Edit ==

Joint
Joirt with Type
 Line: " Front
" Two Lines (" Side
(" Surfface " Plane
& 3D joint

| QK | Cancel

Joint with — select the element of joining.

Type — type of joining the elements: on projection Front, Side, Plane or in 3D joint.
For method Line:

Modify control point of line closest to point of jointing. Select a line to be jointed.

Before:

After:

For method Two Lines:

Modify control point of line closest to point of jointing. Select two lines to be jointed with.
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Before:

After:

In this method of joining the tangent to a line in the end point will be lying in the plane
determined by tangents to other two lines in the place of the joint.

For method Surface:
Modify control point of line closest to point of jointing. Select a surface to be jointed.

Before:
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After:

For surface:

Select a surface to be jointed. Select type of joining in the dialogue box.

Set =

Joirt Surface Options |

| QK | Cancel

Native — ensures contact of surfaces in the boundary line nodes (B-spline nodes). The surfaces
may not be jointed along the whole border.

Exact — the surfaces will be smoothly jointed along the whole border.

Select joining line of two surfaces. Select jointing surface.
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Before:

After:

Element » Straight
This command straightens a part of or the whole control polygon (in space or retaining one of
projections) or a series of control points of the surface.

This will result in straightening of the relevant part of the line or surface.
Select an element to be edited. Select straightening method in the dialogue box.

Edit ==

Straight |

Area of action Saved Projection Knots distribution
(v H.;.“ " Frort £ Initizl

" Part of Knots Row " Side ¥ Even

" All Rows " Plane " By prototype
" Region Rows * MNone

QK | Cancel

The following straightening options and modes are available:

Area of action:
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Row - straightening a whole line (in case of surface — selected knots row).
Part of Knots Row — a part of the control polygon between two knots will be straightened.
All Rows — straightening all surface knots rows (in case of line — it works like Row).

Region Rows - straightening all surface knots rows in selected region.

Saved Projection: - projection to be saved:
Front, Side, Plane — saving of selected line projection.

None — straightening in 3D;

Knots distribution - distribution of knots after straightening:

Initial — original,

Even — equal distance between control points,

By prototype — by the knots distribution prototype on the other element.
For line:

Row:

Before:
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After:
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Part of Knot Row:

Select begin control point/ Select end control point.

Before:

After:
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For surface:
Part of Knots Row:

Select begin control point. Select end control point.

Before:

After:

The area of knots will be straightened according to the selected method.
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Element » Smooth
This command allows smoothing lines and surfaces. Select an element to be edited. In the
dialogue box select smoothing mode and options for a line.

Edit ==

Smoath |

Method

Division of patch: |1
" Fair

Bezier
-

~

Knots to line or suface

O B B

Modes to line or surface

O B B

...............

Ty

Approcdmation

QK | Cancel

Method:

Fair — smoothing consists in projecting the knots on the line itself. The method is effective in
case of a large number of knots and inconsiderable dispersion;

Bezier — the knots are laid on a special Bezier line defined or edited during the smoothing
process.

Knots to line or surface — knots of the specified area of the control polygon are laid on another
(previously specified) line or surface specified by the user on the system request.

Nodes to line or surface — nodes of the specified area of the line are laid on another (previously
specified) line or surface specified by the user on the system request.

Patch — the knots are laid on a special Bezier surface patch.

Edit by patch — the knots are laid on a special Bezier surface patch edited during the smoothing
process.

Approximation — adjustment the curve to approximation points.

Area of action: - area of action during the smoothing process.
All line — area of action is the whole line;

Partial - area of action is a part of the line;

Saved projection:
Front, Side, Plan - saved projection during the smoothing process;

None — without saving in any projection;
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Fair:

Select beginning point/ Select end point. In the dialogue box click Yes to continue. To stop the
process of smoothing click No.

ShapeMaker v1.00 £Z
[ | Repeat (y)?
______________________________ Ves No
Before:

After:
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Bezier:

Select beginning point. Select end point. Bezier curve will be created on top of the selected
area.

Modify position of the Bezier control polygon.

Press Esc after finish the modification. All control point of the curves selected area will jump to
Bezier curve.

Press Esc to exit the smoothing mode and continue correcting the smoothing curve.
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Knots to line or surface:
Select beginning point. Select end point. Select line or surface.
In the dialogue box select the knots distribution options:

Set [l

Ask Saved Projection |

" Projection

" Mo saving
Coordinate:

v ¥ ¥
i {
7 f‘

| QK | Cancel

Save:

Coordinate — according to selected Coordinate

Projection — according to selected Projection

No saving — by shortest distance to line or surface

The selected area of the line will be smoothed in accordance with the selected line.

Before:
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After:

For method Nodes to line or surface: - see method Knots to line or surface.

For method Patch and Edit by Patch: - see method Bezier (difference is only in number of patch
control points).

Select a surface to be edited. In the dialogue box select smoothing mode and options for a
surface.
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Set [l

Surface Smooth Method |

Area of Action

Method (Knots region)
" Adjust to lines or suface o

Fair 3

Knots to line or suface

O

MNodes to line or suface
Patch

Edit by patch
Imterpolation

i B

Direction
)
oy
" 0Z

O I B

* Momal to suface

o

QK | Cancel

Area of Action: - area to be smoothed.

Knots region — smoothing of the knots area;

Knots row — smoothing a series of knots.

Method (Knots region): - method of smoothing the knots area:

Put on lines — approximation a set of 3D lines net of surfaces;

Fair — surface curvature smoothing.

Knots to line or surface — knots of the specified area are laid on another line or surface.
Nodes to line or surface — nodes of the specified area of are laid on another line or surface.

Patch - knots of the specified area are re-interpolated according to the point’s distribution law of
the given area of the B-spline surface;

Edit by patch - knots of the specified area are re-interpolated according to the point’s distribution
law of the given area of the B-spline surface and the user taking control over the reference
points of the specified area of the surface changes position of the knots of the edited surface.
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Method (Knots row): - a method of smoothing a series of knots:
Parametrical line - smoothing consists in projecting the knots on the line itself.

Bezier — the knots are laid on a special Bezier line defined or corrected during the smoothing
process;

Direction: - direction in which the knots or nodes of the surface are moved.
OX —in direction of X coordinate;
OY —in direction of Y coordinate;
OZ —in direction of Z coordinate;

Normal to surface — in direction of a normal to surface.

Saved projection: - saved projection during the process of smoothing.

None — without saving in any projection;

Division patch: - temporary subdivision of the edited surface area into the required number of
nodes.
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Put on lines:
This method allows approximation a set of 3D lines net or surfaces.

Select row knots - specify the main direction of approximation. Select Elements and Press Enter
- select set of 3D lines or surfaces. Select begin point of the control point’s area. Select end
point of the control point’s area.

Before:

After

Fair:

This method allows surface curvature smoothing.

Select begin point. Select end point. To complete the operation press Esc.
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Before:

After:

Knots to line or surface:

For method Knots to line or surface with the area of action on surface, if you want to smooth a
series of knots take the actions similar to those taken to smooth the lines by this method. If you
want to smooth an area of knots, on selecting the area the following request will be displayed:
"Select surface:". Specify a surface on which the knots are to be laid.

Before:
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After:

Nodes to line or surface:

Method Nodes to line or surface are similar to knots to line or surface method, but in this
method all manipulations have to do with nodes instead of knots.

Patch and Edit by patch:

Both methods are similar to same methods for lines, but all manipulation doing with region of
surface knots.

Interpolation:

Interpolation selected area of control points as superposition of boundary lines.
Parametrical line:

Method parametrical line is completely similar to the method fair for a line.
Bezier:

Method Bezier — the knots are laid on a special Bezier line defined or corrected during the
process of smoothing similarly to smoothing the line by this method.

Before:
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After:

Element » Smooth
This command is use to control number of control points b-spline.

Select an element to be edited. In the dialogue box select the mode of modifying the number of
knots for a b-spline.

edit x|

K.nok |
Kot b
 add Mew number of knots: |4
i~ Delete " | Keep shape exactly
*' take even paramstization [T Two-stage method

k. I Cancel

Keep shape exactly — enable or disable this option:
Knot to:

Add - add a knot on the line. Input position of the new knot.
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Before:

After:

Delete - delete a knot from the line. Select knot to delete.

Before:
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After:

On deleting the knot the shape of the line will be changed.

Make even parameterization — make equal parameter distribution along curve. Number of knots
have to be set by user.

Two-stage method —advanced for better shape.

Element » Fixing
This command will assign the required fixation (subtype) to the corrected point or line and
change parameters of fixation or parameters of the size.

Select an element to change the parameters or type of fixation.

Select the desired options and parameters for the spatial point in the dialogue box

Fixing @
Poirt |
Fixing
________________________ [ Position:  |79.7076, 265818, 42217
(¢ ot Foeed
(" Shifted from poirt ) | o
(" Shifted by nomal : I
{" Shifted by nomal to line |: 00
QK | Cancel
Not Fixed — without fixation:
Position - position of the point.
Shifted from point — fixed on shift:
Basic point - 0 — internal point name (number);
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Shift vector - 0, 0, O - vector of shift from the basic point.

Shifted by normal — fixed on shift by normal to surface:
Basic point - 0 — internal point name (number);
Basic surface - 0 — internal surface name (number);

Shift - 0 — distance from the basic point.

Shifted by normal to line - fixed on shift by normal to the line projection:
Basic point - 0 — internal point name (number);

Basic line - 0 — internal line name (number);

Plane normal - 1, 0, 0 — vector of normal to determining plane;

Shift - O - distance from the basic point.

Select the desired options and parameters for the hanging point in the dialogue box

Relative length Brows |

oK | Cancel |

Fixing @
Paint on line |
Foding: Plane Nomal:
Plane Mormal:  |1.0.0
" Mot Fixed T
v T
" Plane from point = 07 l,i
(" Tangent from point % |zam
" Length from point u
~

Not Fixed - without fixation:

Parameter - 0 — parameter of the point on the reference line.

Plane — fixed by coordinate (in plane):

Plane normal - 1, 0, 0 — vector of normal to plane.
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Plane from point — fixed on shift by one coordinate (in plane with shift):

Plane normal - 0, 0, O - vector of normal to plane;
Basic point - 0 — internal point name (number);

Distance - 0 - distance from the basic point to the plane.

Tangent from point — fixed on tangent to reference line:
Plane normal - 0, 0, O - vector of normal to plane;
Tangent angle - 0 — angle of inclination to tangent;

Basic point - 0 — internal point name (number);

Length from point — fixed by length:

Basic point - 0 — internal point name (number);

Length - 0 — fixed length.

Relative length — fixed by relative length of the line:

Length - 0 — fixed relative length; value 0 corresponds to the beginning of the line and value 1

corresponds to the end of the line.

Select the desired options and parameters for the surface point in the dialogue menu:

Fixing @
Surface Point |
Fidng
" Mot Fieed

* Projected
" Projected From Point

Along Vector: |D- 1.0

Brows |

| OK | Cancel |

Not Fixed - without fixation:

Projected — fixed by two coordinates (by vector):
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Along vector - 0, 0, O — projecting vector.

Projected From Point — fixed on shift by two coordinates (by vector with shift:
Along vector - 0, 0, 0 - projecting vector;
Basic point - 0 — internal point name (number);

Shift vector - 0, 0, 0 — shift vector of the basic point.

Select the desired options and parameters to change fixation of the line in the dialogue menu:

Fixing @
Line |

Fixing

* Mot Fxedt 1

" Arc

™ Stright 0.-1

. o

O 's

~

r 1 u

-1, 0
QK | Cancel

Fixing:

Not Fixed — without fixation;
Arc — obtaining and fixing of an arc shape;

Straight - obtaining and fixing of a straight line shape;

Vector — modifying the projecting vector (for surface lines).

Plane - 0, 1, 0 — vector of normal to plane on which the projection of line has the shape of an
arc or a straight line;

Radius (m) - 0 — arc radius;
Orientation - positive/negative - orientation of the arc convexity;

Big arc - no — selecting an arc with a smaller or larger central angle:
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Positive Negative Big arc

Along vector - 0, 1, 0 — projecting vector (for surface lines).
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Element » Surface Orientation
This command allows changing surface orientation.

Choose a surface which necessary to change orientation. To stop the process, press Esc or
right-click the mouse.

Before:

After:

Element » Ortho Line
This command sets tangents to line in the end points vertically or horizontally in the working
plane.

Select a line to be edited. Select the first knot closest to end point of the line. Tangency in this
point will be set up vertically or horizontally depending from previous position of the control
point”.
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Before:

After:

Element » Ortho Surface

This command sets an auxiliary mode of editing the surfaces for boundary knots. After
modification such knot will be “vertical” or “horizontal” in the working plane.

The auxiliary surface editing mode will be enabled. Select a surface to be edited. Select a knot
to be set in the orthogonal position.
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Before:

After:

To switch off the mode, click the Ortho Surface command again.

Element » Tangent
This command is use to set linear depends for tangency along surface’s boundary.

Select begin point of the boundary knot. Select end point of the boundary knot.

Before:
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After:

Element » Connect
This command makes the topological of the elements.

Three methods of transformation are available:
Edit =

Connect |

Operation

(" Disconnect from surface

{" Disconnect from point

| QK | Cancel

Connect to surface:

This option transforms spatial points and lines into surface points and lines. The points and lines
are projected on the surface along the vector perpendicular to the current working plane.

Before:
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After:

Disconnect from surface:

This option transforms surface points and lines and hanging points into spatial points and lines.
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Disconnect from point:

This option “divides” the point into two points thus making the topological dependency of a
certain line on other elements unnecessary.

Select point. Select disconnecting line.

Before:

After:

Element » Extend
This command extends or shortens selected line without changing the shape.

Select a line. Select line’s end point. Move the cursor to extend or shorten the line.
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Before:

After:

Element » Knuckle
This command is used for making knuckles inside surfaces and lines.

For line:
Select line for edit. Select control point where is necessary to have a knuckle.

Before:
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After:
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For surface:

Select surface for edit. Select begi and end points of the row to make knuckle.

Before:

After:

Element » Copy Geometry
This command copies geometrical data from one source element to another.

Select a source element. Select modified elements.

Element » Update
This command is used for modification of the connected elements without finishing with editing
of the master element.

Element » Rebuild
This command is used for redraw surface during editing.
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Element » Options

This menu contains various methods and options for manual correction of lines and surfaces.

Select parameters in the dialogue box.

Edit
Options |

Distance from appro. points:
Calculate additional distance along:

¥ Draw
Rarefy approx. by distance (m): L2
X
|0.001
Y
[v Draw approx. poirts "~z
[v Draw vectors distance " View
Edit style: Certers:
{* Paint [ Draw

" Mrea of points 1

" Region of points
" Al points
" Transform region of poirts

Bending:
[ Draw

v

1 71 %] 5]

Modify connect elements: MNodes: Knots:
* Do not modify [ Edt v Edt
" Al knots except last N i/ Benw pokygon
" Al knaots _
Step of curvity: |10 [ Curvity of neighbour [+ Edit by point

==

o |

Cancel

Distance from approx. points: - visualization and calculation deviations from approximation

points.

Draw — visualization points and deviations

Rarefy approx. by distance (m) - 0.001 — the value which determines the minimal distance

between the used approximation points.
Draw approx. points - draw approximation points
Draw vectors distance - draw deviations vectors

Calculate additional distances along:

None — makes it possible during the correction of surfaces, in addition to the distance in 3D

space.
X, Y, Z-along x, y and z axes respectively;
View — along the sight direction (e.g., in isometry).
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Bending:

Draw - enable/disable inflection lines visualization

Front, Side, Plan - visualization according selected projection
Like Sections - visualization according sections

Gauss’ curvature - visualization according Gauss’s curvature

Edit style:

Single point — single control point modification.
Area of points — area of the control points modification.

Area (in knots): 2 — number affected Bezier patches. The farther is the knot from the edited
knot, the shorter is the distance that it moves. Boundary knots do not move to keep tangents at
the borders of lines unchanged.

Region of points — similar to the previous mode movement of one knot affects a few adjacent
knots.

All points — the same as the previous mode, but editing of one knot affects the whole surface.
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Transform region of points — this mode moves all the knots within the user specified area to an
direction vector and provide adding or reducing of volume.

Center:

Draw - Display the curvature and line bend points (in projection to the working plane) or surface
sections.

Scale curvature radius by - 100 — scale parameter for curvature. The value is the number of
times the length of the segment representing the curvature in the point is less than the radius of
curvature in the given point.

Maximum radius draw - 50 — the maximal radius of curvature displayed on the screen.

Modify connect elements: this option set up medication rules for linked elements. For example,
after changing point position, shape of all lines (connected to the point) will be modified
according following rules:

Do not modify — means only end point of the line will be modified. All other control points will
keep same positions.
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All knots except last — means only end point of the line will be modified.

All knots — all knots will be maodified by linear law.

Contents of the given dialogue box can conventionally be subdivided into the following sections:
correction by knots, nodes.

Nodes:
Edit - allow editing by nodes.

Real-time move node: this parameter indicates whether the whole polygon of the surface will
be redrawn while moving the marker during the correction of surface by B-spline node (this may
be quite slow);
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Knots:
Edit - allow editing by knots.
Draw polygon - allow knots visualization as polygon.

Step of curvature — 10 — number of steps for each curve (surface) segment for curvature
calculation.

Curvature of neighbors — allow neighbors curvature elements visualization.

Edit by point: correction by random point.
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Modify » Block

Menu Block contains the commands for various operations on a group of elements

: File Edit View Draw m Settings  Tools

2 = | o cu [ B 17 Attroute EETEER).
T+ | Copy Attribute

7] hulil X  Delete

m@ hull2 Element

Block =& | Move

Colar Shifted Copy

T Rotated Copy
Symmetry

Rescale

- | By F g LN

Set To Current

Intersection

8

Block » Move
This command moves and rotates groups of elements in the working plane.

Select the elements to be moved. Press Enter after finishing selection.

Select basic point and move object to new position.
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Select a new point.

The elements image in a new position will appear in the model.

If required, move to rotation press Tab key. Specify the center of rotation. Input a base angle of
rotation.

Specify the angle or rotation.
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The elements image in a new position will appear in the model.

Block » Shifted Copy
This command makes shifted copy of the selected elements.

Select the elements to be copied. Press Enter after finishing selection.

Select copy options in the dialogue box.

Elock settings |

[ Make image driver Make copy on:

[ Make new block * (ld support elements

[N

Block name:

Mumber of copies: |1

" New support elements

QK | Cancel

Make image driver - creates an image driver.
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Make new block - creates a block for the copied elements.
Block name - name of the new block.

Number of copies - number of copies to be created. If the number is more than 1 the specified
number of copies will be created. The distance between the copies will be the same as between
the selected elements and the first copy.

Make copy on:
Old support elements — creates a copy with the use of the source reference elements.
New support elements - creates copies without the use of the source reference elements.

Select basic point and copy object to new position.

Copied elements will appear in the model.
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Block » Rotated Copy
This command makes rotated copy of the selected elements.

Select the elements to be copied. Press Enter after finishing selection.

Select copy options in the dialogue box.

Block settings |

[ Make image driver Make copy on:

[ Make new block f* (Cld support elements

Block name: |3~'=""~

Mumber of copies: |1

" Mew support elements

QK | Cancel

Make image driver - creates an image driver.

Make new block - creates a block for the copied elements.
Block name - name of the new block.

Number of copies - number of copies to be created. If the number is more than 1 the specified
number of copies will be created. The distance between the copies will be the same as between
the selected elements and the first copy.

Make copy on:
Old support elements - creates a copy with the use of the source reference elements.

New support elements - creates copies without the use of the source reference elements.
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Specify the center of rotation and vector of the first angle and second angle.

Copied elements will appear in the model.

Block » Symmetry
This command makes mirror symmetry of the selected elements.
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Select the elements to be mirrored. Press Enter after finishing selection.

Select symmetry options in the dialogue box.

=

Symmetry settings |
| Make image driver Flane of Symmetry
[ Make new block ™ Frame

Block name: |l@nk ¥ Buttock
Place of plane {m): |0 " Waterine

| QK | Cancel

Make image driver - crates an image driver.

Make new block - creates a block for the copied elements.
Block name - name of the new block.
Place of plane - distance of the symmetry plane from zero to the relevant coordinate.

Plane of Symmetry - creation of symmetry relative to planes Frame, Buttock, and Waterline.
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Copied elements will appear in the model.
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Block » Rescale
This command makes scaling of the selected elements.

Select the elements to be scaled. Press Enter after finishing selection.

Select basic point of the transformation. Select transformation options in the dialogue box.

==

Scaling |
X
i 1
Y
i !
£
i i
| QK | Cancel
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Scaled elements will appear in the model.

Block » Set To Current
This command change block’s attribute of the selected elements. All selected elements will be
transferred to the current block.
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Block » Intersection
This command creates intersection lines of all the surfaces included in the intersected blocks.

Select first and them second blocks from block tree:

Operation

Block Tree |

El..

7 hullf13
&3 decks

..... D 1dk

=+ E8 Appendix
..... 15 Thrusters
=& (2 Bilge keel
7] [ Profile
7] Line Marintek
.. ;7] (Bl BK Marintek
----- 5[] Moonpool
=[] @ stern-tube
..... [C)(E3 skeq
2@ shaft

7] (B ShaftBracketTo CL
... 7] (28 ShaftBracketToSide

m

1

o< |

Cancel
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Intersection lines will appear in the model.

Modify » Color

Select an element to change its color to the current color of the system.

Modify » Properties

This command is used to obtain information on a project element.

Select element. View information about the element in the dialogue box.

=

ShapeMaker +v1.00 EE

|gu Line 26276
W' block 26224 "pipe”
~ end points 26271, 26274
dimension 49, 51, 51
intersection of surfaces 26221 and 26229

total length 46717

Yes Mo

To cancel viewing click No. To view backward references click Yes, you will see a list of
elements in the dialogue box.
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Settings

Settings Menu contains commands that allow modify current settings.

i File Edit WView Draw Modify Tools Help
Object snap

Current Plane

=[] [l rudder

=57 & hull
=& hull 0

& hulla 0

Current Point

(1 B @

Section Plane
Elements Visibility
Set By Element

i

Cursor
Selection Type
Current Surface

Grid

WS

Colar

Settings » Object Snap
Command is used to control enabling and disabling the object snaps.

Enable or disable snaps in the dialogue box.

Set ==

Object snap filters |

— Paint — Line

[ Locate 2d position by point { Pri2D )
[T Locate 3d position by point { Pri30 )
[ Link to poirt  Poirt )

—(Grid

[” Locate 2d position on line ( Line 20 )
[ Locate 3d position on line { Line 30 )
[~ Link toline { Line )

[ Locate paint on grid knot (Grid )
™ Locate point on grid X { Grid X )
[T Locate point on grid ¥ { Grid ' }
™ Locate point on grid Z { Grid Z )

— Surface

[T Locate point on suface { Surd 3D )
[~ Link to surface { Surf )

— Puds

Misc

[T Setfudng X (¥)
[ Setfiing ¥ ()
[ Setfuing Z(Z)

[ Fittering by elements of extemnal block { Block )
[™ Locate 3d postion by approximation point { Appr )
™ Fixing of paint { Fix )

| QK I Cancel
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Point:

Pnt2D — geometrical snap to the selected point by two coordinates of the point in current
working plane.

Pnt3D — geometrical snap to the selected point in three coordinates.
Point — topological link to the selected point.

Line:

Line2D — geometrical snap to the line in two coordinates in current working plane.
Line3D — geometrical snap to the line in three coordinates.

Line — topological link to the line.

Grid:

Grid — geometric snap to the grid knot.

GridX — geometric snap to the grid in X

GridY— geometric snap to the grid in Y

GridZ—- geometric snap to the grid in Z

Surface:

Surf3D — geometric snap to the surface in three coordinates

Surf — topological link to the surface;

Axis:

Snap with assignment of X, Y, Z coordinates.

X —snap in X coordinate;

Y —snap in Y coordinate;

Z —snap in Z coordinate;

Misc:

A snap to more than one object can be simultaneously performed. For example: a snap to the
line and to the grid line. For this purpose establish the required combination of the snap modes.

Appr — snap to the approximation point;
It allows performing a geometric snap to approximation points.
Block — snap to the block element;

Fix — snap with fixation;
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When performing the above said object snap methods the point may assume only few fixation
types. Snap with fixation allows assigning any other type of fixation to the point (the same result
can be obtained with the help of command Modify » Edit » Fixing).

Settings » Current Plane
This command allows setting the working plane parallel with the main planes in isometrics, i.e.
one of the coordinates X, Y or Z is not changed.

Select the work plane in the given dialogue box.
et ==

Cument working plane |

" Front
* Side
" Plan

" Screen

| QK | Cancel

Settings » Current Point
This command allows changing position of the current work point so as to change position of
the work plane.

The work point will automatically change its position when carrying out operations for
construction of elements. In this case the last input point is saved as the work point, for
example, the end of the line.

Input the work point by request.

Settings » Section Plane
This command is used for the plane and the number of surface sections in planes
X, Y, Z to be displayed on the screen.

When the dialogue box appears select the parameters for display of the sections.

Set ==
Secart Plane |
Secant Plane: Type:
{* Frort " by window 5l
" Side *" by grid I
" Plane 5
| QK | Cancel |
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Secant Plane sets a plane of sections for isometric view.

Type sets a number of sections in the grid or by the number that you define in the text fields

Front, Side and Plan.

Settings » Elements Visibility
This command is used to control visibility of the elements at the various.

When the dialogue box appears sele

ct the elements to be displayed on the screen.

Set &2 |
Levels |

I+ Pairt I Cuttings [ Detail

v Line | Template v Approx

[ Surface [ Section v ldert

v Rendersd Suface W Size [ Grd

| Crientated Surface

QK Cancel

Settings » Set By Element
Set By Element Menu contains the commands which allow setting current block and color
same as selected element.

: File Edit

e

B El o «| ?

Set By Element » Block

This command allows setting a current block by any selected element of the model. A new

current block will be the same as blo

Set By Element » Color

This command allows setting a current color by any selected element of the model. A new

View Draw  Modify _ Tools

= | rudder @ | cCurrent Plane
o =7 hull HH | current Point
O =3 hull 0 =2 | Section Plane
2t I R D hulla 0 £5 | Elements Visibility
el EI hullm Set By Element »| T3 Block
) = []ER decks
_____ D ttop Cursor T& Color
211 N I w758 2dk Iy | Selection Type T4 Block And Color
@ EI 1dk Q Current Surface
----- &3 adk B | Grid
#» El bdk 1 color
Y E| cdk

Help

Object snap

ck of the selected element.

current color will be the same as that of the selected element.
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Set By Element » Block And Color
This command allows setting a current block and color by any selected element of the model. A
new current block and color will be the same as those of the selected element.

Settings » Cursor
Cursor Menu contains the commands which allow defining marker moving rules.

: File Edit View Draw Modify | = .| Tools Help
BEEE o o« B

e

Object snap

5""'D rudder |§] Current Plane
v EHZl hull EH | current Point
& =& hull 0 = | section Plane
g CJE hulla 0 A5 | Elements Visibility
T A I EI hulim Set By Element r
. =B decks
_____ | ttop Cursor k| W | Options
ij _____ 75 2dk E& Selection Type / < etDir
..... El 1dk ﬁ? Current Surface | setpol
— - etPole
I I R (I adk HH | Grid B s
= etline
""" E bk || | Colar
ol B cdk ——

Cursor » Options
By this command user can set limitations for cursor movement.

In the dialogue box select required limitation for cursor movement.

Set ==

Marker |
" None ¢ Dirzd Secale value {mm):
" Ort ' Dirdd
" Dir |-I
" Dir Pale
~ DirOrt [ Scale
" Dir Line | Deep

QK | Cancel

Ort - Orthogonal direction on current projection plane.

Dir - Direction predefined by command SetDir.
Dir Pole - Direction predefined by command SetDir and pole predefined by command SetPole.

Dir Ort - Direction predefined by command SetDir.

Dir Line - Direction predefined by command Set Line. Cursor will follow line .
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Dir2d - Direction predefined by command SetDir only in a working plane.
Dir3d - Direction predefined by command SetDir in 3D space.
Scale - Enable scalable cursor movement.

Deep - Enable cursor movement in perpendicular to working plane direction.

Cursor » Set Dir
This command allows specifying a straight line, which defines direction of the point offsetting in
the modes Dir, DirPole and DirOrt.

In the dialogue box select the point offsetting direction method.

=

Set Direction |

" Momal to projection of line
" Tangent to line

" Momal to suface

| QK | Cancel

Two Points — a straight line passing through two points.

Angle - a straight line passing through a point at a specified angle of slope (in the current work
plane).

Normal to projection of line — a normal to projection of the frame line on the work plane.
Tangent to line — a tangent to projection of the frame line on the work plane.

Normal to surface — a normal to surface in the specified point.

Cursor » SetPole
This command is used for input of a point - pole for movement of the point in mode DirPole.

Cursor » SetlLine
This command allows selecting the point movement line in the mode DirLine.

Settings » Selection Type
This command is used to operate with selected elements at the same time (for example: to
delete a group of lines without successively specifying each line).

In the dialogue box choose the selection type:
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Set 5

Selection Type |

| QK | Cancel

Tree — select block from blocks tree.

Block — select block by any element of the block.

Element - one by one selection of separate elements.

Settings » Current surface
This command is used to select a default work surface for creation of a lines on surface.

Settings » Grid

This command is used to specify a User Coordinate System (UCS) and grid of the project Lines
Drawing (LD).

Change Shape Maker Configuration @
Coordinate system and Grid |
" Ordinate " Applicate 2
Mumbering of sections:
{* |eft to ight * negative
" right to left " postive
Position of zero section: |0 Intermediate sections: |0
(Grid (begin, end and step): Additional sections:
540,06 6.7
0.6 06
6 134107
1341,1473, 06
1 1 F ] T P
| QK | Cancel
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By default the UCS coincides with internal (mathematical) coordinate system and the LD grid
has the following dimensions: 100x50x50 meters with an interval between sections of 10 meters
in each axis.

The grid axis is selected with the help of the keys Abscise (Abscises) X, Abscise Y, Abscise Z.

Direction of the grid in axis X is specified from the left to the right or from the right to the left with
the help of the following options Direction of Axis: left to right or right to left.

Forward and back direction of the grid in axis Y is specified with the help of the following options
Direction of Axis: to you (back) or from you (forward).

Bottom-up or top-down direction of the grid in axis Z is specified with the help of options
Direction of Axis: down to up (bottom-up) or up to down (top-down).

Coincident and opposite direction of the numeration of sections with the help of the following
options Numbering of Sections: negative or positive.

Position of zero section - makes possible to set numeration of sections so that the section with
number O will not coincide with coordinate O corresponding to the coordinate system axis.

Intermediate sections — number of sections between grids sections.

Grid (begin, end step) - makes possible to set the beginning, the end and step of the area.

Additional sections - allows additional sections with defined coordinates.

Note:

Interval between begin and end must contain only whole number of steps. Otherwise the error
message will be shown.

Settings » Color
This command is used for setting a current color.
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Cument color;

HE NN
B B e
N E N =
B e

| QK | Cancel

Click on the desired color. The selected color will appear in the window Current color. To
confirm the selection click OK. All newly created elements will have the selected color.

Tools

Tools Menu contains commands that allow to make database check, measure distances and
angles, use some auxiliary calculations.

: File Edit View Draw Modify Settings

BEEEl o | ?

==l )3 rudder Distance
< =& hull Curvature
H ED hull 0 Calculator
4 """ D hulla0 E Valume Parameters
S .| (& hullm
o ElD decks Options
Pl e Han

Tools » Check

This command allows testing the internal database structure, checking dependencies between
the elements and properly correcting errors in most of the cases.

Select database checking options in the dialogue box.
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Check correctness and view of bkl database structure @

Things to check |

v Feferences

[+ Geometry
Special precigion: |E'-D|3'|3"|

Limits: [0 . |[:l

[ Tryto comect Iv Make statistics
W Make report [+ Stop when emor

Report file:
C:%Users'salt\Documents M5 1% Project

| QK | Cancel

Belongs - a feature, indicating a necessity of checking the correctness of “master” for each
element. For lines, points and surfaces: affiliation with the block will be checked, and for
approximation points — lines or surfaces and etc.

References - indicates a necessity of checking the correctness of references between the
elements.

Geometry - the geometry check is checking whether the ends of the lines match their end points
and whether the hanging points exactly fit the reference line and etc.

Special precision - database checking precision.

Limits of checking 0, O — the range of the checked names. You can narrow the range of the
checked names. You can also set the initial and final database element to be checked. The
default setting is "0, 0", which corresponds to checking of the whole database.

Try to correct - this option corrects the errors revealed. Corrections may include changing
references or the type of an incorrect element, deleting of the latter or rebuilding the geometry.

Make statistics - when this option is enabled the system will make statistics of the data base
during the check (total number of elements and of each type, total number of links, average
distance between the depending elements, name space fill and etc.). On completion of checking
the report file can be read.

Stop when error - stop when an error occurs. With the help of this option the user can get the
information when an error is revealed and take a decision on its correction and whether the
check will be continued or terminated.

Make report - this option indicates to the system the necessity of creating a report on the
operation. In case of any errors revealed the system will make it possible to view the report file
on completion of the check.
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Report file - checkbkl.Ist — name of the report file.

Tools » Distance
This command measures distance between two points, inclination angles of lines, lengths of the
liners and other geometrical characteristics.

-

[l

(Get Geometric Information |

[v Distance between poirts: [ Angles with coord axes

[ Length of line between points [ Inclination on projections
[ Vector coordinates [ Angle by three points

QK | Cancel

Distance measurement result:

ShapeMaker v2.00 @

Distance = 43,1251 m,
l % Cannot detect line,
Vecton
Dx = 35.2628 m,
Dy = 0.0000 rmn,
Dz = -24 8257 m,
Angles with axes:
X:35146 deg,
: 90.000 deg,
Z:125146 deg,
Angles on projections with axes:
Front - with ¥: -90.000 deg,
Side - with X: -35.146 deg,
Plan - with X: 0.000 deg

Tools » Curvature
This command visualizes curvature and inflection lines for selected surfaces.
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Tools » Calculator
The calculator helps to make simple calculations with variables and frame numbers. Variables
can be also used in command string for definition of the points coordinates.

Calculator @

|a=x1 E-0.3| QK

Cancel

The expressions can also be used in the prompt when entering the numerical expressions (for
example, when entering a point coordinates). Calculator has collection of the mathematical
functions and collection of variables, signed by the Latin letters from a to z. The calculator save
variables contents during working session.

In the calculator are available the following operations (in the follow of priority):

, (comma) - means, that previously calculating value from the left and after that — the result from
the right from it (for example the expression “a = sin(x), a + a” will give value 2*sin(x)). Except it
comma used for dividing setting numbers and arguments of the functions;

= equalization;

+ , - addition and subtraction;

* [, % multiplication, division and the rest from division on the whole number, correspondingly;
A raising to the power.

Mathematical functions:

abs (x) - ||,

acos ( x) - arccos X,
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asin ( x) - arcsin x,
atan ( x) - arctg X,
cos (X)) - cos X,
ch(x)-chx,

exp (x) - ex,

int (x) - [X],
In(x)-Inx,

lg (x) -1og10 x,

sin (x) - sin X,

sh (x) - shx,

sqrt (x) - VX,

tg (x)-tgx,

th (x) - th x,

rad ( x) - xx p /180,
deg (x) - xx 180/p
Predefined variables:
a=1/137,

c = 2.997925*1010,
e = 2.71828182845904523536,
f=2.9*1014

g = 6.672*10-23,

h = 1.0546*10-27,

k = 1.38*10-16,

m = 0.911*10-27,

n = 6.0222*1023,

p = 3.14159265358979323846,
q = 4.803*10-10,

r = 8.314*107,

s =0.577215664.

Other variables defined by zero.
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Tools » Volume parameters
Simple hydrostatics calculations can be performed by this command.

Settings @

Volume |

™ fia Draigh i |° Specic Water Weight §/m3): |1
Type: .
= Cet Girids | Draught m): |0

{+ Symmetrical

Heel ({deqg): |0
" Right Side cel {deg)
" Left Side Trim (deg): |0

0K | Cancel |

Max. Draught — maximum loaded draught

Type:

Symmetrical — symmetrical.

Right side - starboard.

Left side - port side.

Set Grids - formation of the own grid ( only frames spacing can be defined) .
Specific Water Weight (t/m3) — water density

Draught (m) — draught

Heel (deg) — angle of heel

Trim (deg) — angle of trim

Results of the calculations:
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ShapeMaker v2.00 @

Displacernent(t)=1524.734799
b Wet. Surface=721.207229
S/LB=0.630379
V/LBT=0.537825
FO/BT=0971477

Center of buoyancy:
XC(m)=53.602919

Y C{rn)=0.000000
ZC(m)=1.611950

Tools » Options
Simple hydrostatics calculations can be performed by this command.

Change Shape Maker Configuration @
Graphics | Common Options | Template Options |

Paths

Graphic corfiguration: |TieogneReie |
Librany path: |n:::"-Ji|:| |

Calar
Marker Size |D.3‘I 0586395460666
|Grids |
Code Page:
™ OEM - Change |
¥ ANSI

| QK | Cancel

Graphic configuration - smconfig.cfg — name of the file which contains information on the
graphics options (by default - smconfig.cfg).

Library path - c:\ lib — directories where the library files will be searched. You can set several
paths divided by a semicolon.

Color:

Grid — Grids Color
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Window Background - Window Background Color
Code page - selection of coding.
ANSI —ANSI Windows coding page

OEM — OEM coding page

Change Shape Maker Configuration @

' Graphics Commen Options | Template Options |

Mumber of saved windows: Approx. paoints image:
E ¢ Point:
" Cross
Subdivision of line for: Digplay grid image:
Diisplay: 20 " Grid
* Scale
Subdivision of sections for: Subdivision of contour on surface:
Display: |2|} |25

Subdivision of suface for:

Display: |4
DXF: |4
Hydrostatics: ¢

Ok | Cancel |

Number of saved windows - 5 — number of windows to be saved (from 2 to 5) for command
Window » Prev.

Subdivision of line for Display - line representation quality (number of line points per Bezier
segment) to be displayed on the screen.

Subdivision of sections for Display - size of matrix of sections displayed.
Increase size of the matrix for better display of sections.

Subdivision of contours on surface - 25 — representation of cutout borders on the surface
(similar to representation of lines).

Subdivision of surface for - size of matrix of surface displayed (number of lines of equal
parameter):

Display - 4 — for displaying on screen,
DXF - 4 — for creation of DXF file.
Hydrostatics - 8 — for creation of STC statics file.

The more is the number of points, the better is the quality of representation of lines. Besides, it
slows down the display and increases size of the DXF - file;
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Approximation points image - quality of representation of approximation points.
Point - as points,

Cross - as asterisks.

Display Grid image: - grid display type.Grid - as grid,

Scale - as a contour of lines limiting the volume and marks in such lines.

Change Shape Maker Configuration @
Graphics | Common Options ~ Template Options |

Template paths

Template file name: ||

Output options Shifting vector
[ Lines output

0
[ Surface outpud ! | m

Scale Y |[:| m

|'I z |D m
Angle
|D

| QK | Cancel

Template options used for visualization of CFD results and other 3D model saved in files TPL.

Template file name — name of the file for visualization.

Output options:

Lines output — visualization of the lined ( for example stream lines )
Surface output — visualization of the surfaces like wave pattern.
Scale — scale of the model.

Angle — trim angle of the model.

Shifting vector — defined possible shift of the model O position.
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i File Edit WView Draw Modify Settings Tools
T EEEl o = ?

o EI hull
4 hull
O & huli2

ShapeMaker Help

License Server
? About ShapeMaker

Contain help information, license server connection and release data.

Help » ShapeMaker help

Show this manual.

Help » Check for update

Provide check for new release on Shape Maker release server. ( For registered users only ).

Help » License server
Provide connection to the license server.

Server connection @

To establish connection to the ShapeMaker
license server please input server name
and port.

Server name &port: | MsInz 1 : | =000

K | Cancel

Input server name or IP address and port number.

Help » About ShapeMaker

Show this window.
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Product Info @
-\ i

e T N | S,
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